ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-1499) Platform .Net: fix naming and use properties where appropriate in the API
Date Thu, 17 Sep 2015 13:21:05 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-1499?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14802899#comment-14802899

ASF GitHub Bot commented on IGNITE-1499:

GitHub user ptupitsyn opened a pull request:


    IGNITE-1499 Platform .Net: fix naming and use properties where appropriate in the API


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/ptupitsyn/ignite ignite-1499

Alternatively you can review and apply these changes as the patch at:


To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #97
commit b87dede5d80100feec160561824f80f6e56617b1
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T12:55:21Z


commit 0e319af45d8bb258c55352a32a1c440eb48de4b6
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T12:57:37Z


commit 884ab5e14c38e8a9ab4db2bcd8d7c7f4f87acd06
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T12:59:38Z


commit 795424bb155f2a985ab4a5915738c4fe12525c13
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T13:01:53Z


commit 60cc89fd35a3fe009a85e7c13f201f61c94c5e3d
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T13:04:13Z


commit d86b8a80c05075c2ad910be6b51078ae4732bc75
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T13:06:07Z


commit 58846e4442c8cbde55b91e8167cbb0a9e326b045
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T13:08:47Z


commit 73da409f5f33be71c62ad909df27aa82cb6394b8
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T13:11:02Z


commit 9866c016956029d3d8f799e9e7ecfe1604496d50
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T13:13:36Z


commit 74c4b01833f43c4cbcffd13a7dfd1dfd1373ec6c
Author: ptupitsyn <ptupitsyn@gridgain.com>
Date:   2015-09-17T13:16:11Z



> Platform .Net: fix naming and use properties where appropriate in the API
> -------------------------------------------------------------------------
>                 Key: IGNITE-1499
>                 URL: https://issues.apache.org/jira/browse/IGNITE-1499
>             Project: Ignite
>          Issue Type: Sub-task
>          Components: interop
>    Affects Versions: ignite-1.5
>            Reporter: Pavel  Tupitsyn
>            Assignee: Pavel  Tupitsyn
>             Fix For: ignite-1.5
> * Methods should comply to naming conventions: GetEvents() instead of Events()
> * Change IIgniteTransactions to be a method like all other things. Properties are not
suitable because we may return different instances in future.
> * Compute(IClusterGroup) and similar methods are redundant, get rid of them to clean
the API.

This message was sent by Atlassian JIRA

View raw message