ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pavel Tupitsyn (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IGNITE-1499) Platform .Net: fix naming and use properties where appropriate in the API
Date Thu, 17 Sep 2015 12:52:04 GMT

     [ https://issues.apache.org/jira/browse/IGNITE-1499?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pavel  Tupitsyn updated IGNITE-1499:
------------------------------------
    Description: 
* Methods should comply to naming conventions: GetEvents() instead of Events()
* Change IIgniteTransactions to be a method like all other things. Properties are not suitable
because we may return different instances in future.

  was:
* See IIgnite & IClusterGroup: things like Events() and Compute() can be changed to properties.
* Things like Events(IClusterGroup) are redundant and should be removed from API
* Methods should comply to naming conventions: GetEvents() is a method, Events {get;} is a
property


> Platform .Net: fix naming and use properties where appropriate in the API
> -------------------------------------------------------------------------
>
>                 Key: IGNITE-1499
>                 URL: https://issues.apache.org/jira/browse/IGNITE-1499
>             Project: Ignite
>          Issue Type: Sub-task
>          Components: interop
>    Affects Versions: ignite-1.5
>            Reporter: Pavel  Tupitsyn
>            Assignee: Pavel  Tupitsyn
>             Fix For: ignite-1.5
>
>
> * Methods should comply to naming conventions: GetEvents() instead of Events()
> * Change IIgniteTransactions to be a method like all other things. Properties are not
suitable because we may return different instances in future.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message