ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Goncharuk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IGNITE-946) Need to expose versioned cache entry to public API
Date Mon, 10 Aug 2015 21:11:45 GMT

    [ https://issues.apache.org/jira/browse/IGNITE-946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14680775#comment-14680775

Alexey Goncharuk commented on IGNITE-946:

I see your point about confusing method name, I am ok with renaming it to something like topologyOrder.

The idea of this sum is to provide a number which will monotonically grow with each grid topology
change (even if you restart the whole grid). I briefly looked at the current invocations of
{{topologyVersion()}} method of version and did not find anything that would expect it to
be the same as discovery topology version.

As for the code snippet you mentioned, it obviously is a bug, but I do not think it is related
to the method naming - the code is inside the next() method and the fix would be to simply
move {{adjustedTime}} call before adding current time.

> Need to expose versioned cache entry to public API
> --------------------------------------------------
>                 Key: IGNITE-946
>                 URL: https://issues.apache.org/jira/browse/IGNITE-946
>             Project: Ignite
>          Issue Type: Bug
>          Components: cache
>    Affects Versions: sprint-4
>            Reporter: Valentin Kulichenko
>            Assignee: Denis Magda
>            Priority: Critical
>              Labels: Usability
>             Fix For: ignite-1.4
>         Attachments: ignite-946-2.patch, ignite-946-3.patch, ignite-946.patch
> Currently we have versioned entry, but it's not available on public API, but knowing
version can be useful in some cases. Need to make it accessible via {{unwrap}} method.

This message was sent by Atlassian JIRA

View raw message