ignite-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Artem Shutak (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (IGNITE-1010) Wrong result for ServiceExample when it start without remote node
Date Wed, 08 Jul 2015 12:47:04 GMT

     [ https://issues.apache.org/jira/browse/IGNITE-1010?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Artem Shutak resolved IGNITE-1010.
----------------------------------
    Resolution: Fixed

Ready for review.

The fix is about to print message at log AND at Console (so user will see what happen without
log).

> Wrong result for ServiceExample when it start without remote node
> -----------------------------------------------------------------
>
>                 Key: IGNITE-1010
>                 URL: https://issues.apache.org/jira/browse/IGNITE-1010
>             Project: Ignite
>          Issue Type: Bug
>          Components: general
>    Affects Versions: sprint-6
>         Environment: Ubuntu 14.04/Win7, community version 1.1.2, build 86, rev. 420b6bd82501a3f47388865ecbdf53ce1162462c
>            Reporter: Vasilisa Sidorova
>            Assignee: Artem Shutak
>             Fix For: sprint-7
>
>         Attachments: ignite-6dc4264d.log
>
>
> ---------------------------------------------
> DESCRIPTION
> ---------------------------------------------
> Service Example doesn't stop running if it's running without remote node
> ---------------------------------------------
> STEPS FOR REPRODUCE
> ---------------------------------------------
> 1. Run ServiceExample
> ---------------------------------------------
> ACTUAL RESULT
> ---------------------------------------------
> Example doesn't stop running. There is TcpDiscoverySpi warning in the example's node
log:
> {noformat}
> [22:32:13,759][WARN ][tcp-client-disco-msg-worker-#4%null][TcpDiscoverySpi] Failed to
connect to any address from IP finder (will retry to join topology in 2000ms): [/127.0.0.1:47507,
/127.0.0.1:47504, /127.0.0.1:47502, /127.0.0.1:47501, /127.0.0.1:47505, /127.0.0.1:47509,
/127.0.0.1:47506, /127.0.0.1:47508, /127.0.0.1:47503, /127.0.0.1:47500]
> {noformat}
> Look at the attached log
> ---------------------------------------------
> EXPECTED RESULT
> ---------------------------------------------
> Example stop running with message: "Server nodes not found (start data nodes with ExampleNodeStartup
class)"
> ---------------------------------------------
> ADDITIONAL INFO
> ---------------------------------------------
> 1. This is recent issue. It wasn't reproducible for community version 1.0.6 build #22,
rev. 4b4158f752ee1565539ca4977464f8d7ee6de40b
> 2. The same  behavior is for streaming examples (StreamVisitorExample,  StreamTransformerExample)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message