ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladimir Steshin <vlads...@gmail.com>
Subject Question: Table scheme 'default'
Date Wed, 29 Jan 2020 08:16:40 GMT
Hi ppl. Wanted to ask is issue a bug. Minor propably.

Recently noticed that one simple query returns a value which can't be found
'as is' in following query. I tried to find and drop all the tables I
created with "create table":

select schema_name, table_name, cache_name from sys.tables

And there are tables which were not created with 'create table...'. For
example, table 'default.Person' from the test/tutorial I was researching.
Ok. I tried to delete them too. Now I know this is prohibited. But why I
got error: scheme 'default' not found? I just received this schema name
from previous query.

To avoid this I had to capitalize schema name taking it into "":
"default".Person. Then I got normal error like 'only cache created tables
can be removed with drop table.'.

One select returns value which can't be found in second select
(delete/drop). Isn't it a bug from SQL's point of view?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message