ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Magda <dma...@apache.org>
Subject Re: Getting errors while setup new cluster using existing cluster data
Date Mon, 02 Dec 2019 19:28:36 GMT
Hi Gangaiah,

Not sure that removal of WAL and cp is a good idea as long as those can
keep info about changes that were not applied checkpointed or applied to
persistence files yet.

A safe way to copy the data is to turn off the write workloads to the
primary cluster, ensure that checkpointing is finished and then copy the
data files.

Another approach is to replicate changes to another cluster via Kafka-like
approaches or use snapshots of GridGain.

-
Denis


On Mon, Dec 2, 2019 at 9:30 AM Gangaiah Gundeboina <gangaiah.yadav@gmail.com>
wrote:

> Hi Guys,
>
> We have one live cluster(2.6 native persistence) which serving read and
> write continuously. Want to setup new cluster using existing cluster data
> without stopping.
>
> After coping the existing cluster data files, removed metastorage, wal, wal
> archive and cp data. And then started the all nodes, getting errors while
> cluster activation like jvm pause and record search.
>
> To do this, can some one suggest us what all things need to take care
> before
> staring nodes in new cluster.
>
>
> Thanks in advance.
>
>
>
> --
> Sent from: http://apache-ignite-developers.2346864.n4.nabble.com/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message