ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexey Goncharuk <alexey.goncha...@gmail.com>
Subject Re: Discovery-based services deployment guarantees question
Date Tue, 24 Dec 2019 09:10:48 GMT
Well, this is exactly the case. The service is deployed from node A, the
proxy is created on node B, and "service not found" exception gets thrown
to a user anyway. Perhaps, the retry happens too fast?

Created a ticket [1].

[1] https://issues.apache.org/jira/browse/IGNITE-12490

пн, 23 дек. 2019 г. в 22:08, Vyacheslav Daradur <daradurvs@gmail.com>:

> Hi, Alexey
>
> Please attach a reproducer to the ticket.
>
> As far as I remember we have the following behaviour for the proxies:
>
> Let's assume you have deployed service from node A, then:
> * if you invoke service locally from node A - it is guaranteed to
> service to be deployed and ready to work
> * if you take a proxy from node A to remote node B right after deploy
> - there is might be a race between disco-spi (a message which releases
> deployed service)  and comm-spi (remote call works via Compute over
> comm-spi), but it shouldn't affect end-users because the failed
> request will be retried in this case
>
>
>
>
> On Mon, Dec 23, 2019 at 6:55 PM Alexey Goncharuk
> <alexey.goncharuk@gmail.com> wrote:
> >
> > Nikolay,
> >
> > Yes, I've rechecked, the new service processor is being used. I'll file a
> > bug shortly.
> >
> > пн, 23 дек. 2019 г. в 17:33, Николай Ижиков <nizhikov@apache.org>:
> >
> > > Alexey, are you sure, you are testing new service framework?
> > >
> > > Is yes - you definitely should file a bug.
> > >
> > > > 23 дек. 2019 г., в 17:02, Alexey Goncharuk <
> alexey.goncharuk@gmail.com>
> > > написал(а):
> > > >
> > > > Igniters,
> > > >
> > > > I have a question based on one of my recent tests debugging.
> > > >
> > > > The test is related to Ignite services. I noticed that sometimes a
> proxy
> > > > invocation of a newly deployed service fails because the service
> cannot
> > > be
> > > > found. I managed to reduce the test to a simple "start two nodes,
> deploy
> > > a
> > > > service, create a proxy, invoke the proxy" scenario. The proxy
> invocation
> > > > fails in about ~80% of runs.
> > > >
> > > > As far as I remember, the new discovery-based service deployment was
> > > > supposed to be synchronous, so not only non-proxy service instances
> > > should
> > > > work, but the proxies as well. Was my understanding correct? Should I
> > > file
> > > > a bug for the observed behavior?
> > > >
> > > > --AG
> > >
> > >
>
>
>
> --
> Best Regards, Vyacheslav D.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message