ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Pavlov <dpav...@apache.org>
Subject Re: SpiUriDeploy TC job fails on Java 9+
Date Wed, 03 Jul 2019 10:23:29 GMT
It was by mistake. Let's drop 9 && 10 compilation.

ср, 3 июл. 2019 г. в 12:54, Ilya Kasnacheev <ilya.kasnacheev@gmail.com>:

> Hello!
>
> Dmitry, why did you switch maven.compiler.target to 11 when using Java 9+
> in maven.compiler.target? Indeed it breaks compilation on Java 9-10. This
> is in IGNITE-11189
>
> BTW they are unsupported now, maybe we just drop them for good? Ivan what
> do you think?
>
> Regards,
> --
> Ilya Kasnacheev
>
>
> ср, 3 июл. 2019 г. в 11:39, Павлухин Иван <vololo100@gmail.com>:
>
>> Hi Ilya,
>>
>> Yep there is no problem with Java 12 and 11 as well because a
>> following option is specified in parent pom:
>> <maven.compiler.target>11</maven.compiler.target>
>>
>> The only easy way I found is to use
>> <maven.compiler.target>9</maven.compiler.target> (for java-9+
>> profile). Another option could be supplying maven with
>> -Dmaven.compiler.target argument calculated for a used jdk version.
>>
>> What do you think?
>>
>> вт, 2 июл. 2019 г. в 16:58, Ilya Kasnacheev <ilya.kasnacheev@gmail.com>:
>> >
>> > Hello!
>> >
>> > I have just tried, looks like it is buildable with Java 12 (provided
>> that
>> > -Dmaven.javadoc.skip=true is specified)
>> >
>> > Regards,
>> > --
>> > Ilya Kasnacheev
>> >
>> >
>> > пн, 1 июл. 2019 г. в 22:04, Павлухин Иван <vololo100@gmail.com>:
>> >
>> > > Hi,
>> > >
>> > > SpiUriDeploy fails on TC when it is run with any Java 9+ version [1].
>> > > The reason is very simple, it contains one preliminary build step
>> > > which is forced to run with Java 8. But for Java 9+ builds we pass
>> > > module-related arguments and consequently it leads to Java 8 failure
>> > > (unknown argument). I tried to run that step on JDK used for all other
>> > > steps but faced a compilation error. It was on Java 9 and it said that
>> > > target version 11 was not supported. Due to some reason we configure
>> > > <maven.compiler.target>11</maven.compiler.target> in parent
pom for
>> > > java-9+ profile.
>> > >
>> > > In my mind simple solution here is to set target version to 9. But
>> > > perhaps there is a clever way to use maximum version supported by a
>> > > used JDK.
>> > >
>> > > Do you have an ideas?
>> > >
>> > > [1]
>> > >
>> https://ci.ignite.apache.org/viewType.html?buildTypeId=IgniteTests24Java8_SpiUriDeploy&branch_IgniteTests24Java8=%3Cdefault%3E&tab=buildTypeStatusDiv
>> > >
>> > > --
>> > > Best regards,
>> > > Ivan Pavlukhin
>> > >
>>
>>
>>
>> --
>> Best regards,
>> Ivan Pavlukhin
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message