ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Kozlov <skoz...@gridgain.com>
Subject Re: Options naming format in control.sh utility.
Date Fri, 11 Jan 2019 11:12:03 GMT
Sergey,

Thanks for raising up the question.

Did you mean following (?):
 - boolean argument: *--word1-word2*
 - single value argument  *--word1-word2=value*
 - multiple values argument  *--word1-word2=value1  --word1-word2=value2*


On Fri, Jan 11, 2019 at 2:05 PM Sergey Antonov <antonovsergey93@gmail.com>
wrote:

> Hi, Igniters!
>
> I want discuss and define options naming format in our utilities. I found
> two naming styles in CommandHandler class  --excludeCaches and
> --skip-zeros.
> I think we should unify it. At this moment almost all options have second
> naming format. I am offering rename --excludeCaches to --exclude-caches and
> define format for future options. How about linux like format i.e.
> --word1-word2?
>
> --
> BR, Sergey Antonov
>


-- 
Sergey Kozlov
GridGain Systems
www.gridgain.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message