ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Magda <dma...@apache.org>
Subject Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8
Date Thu, 10 Jan 2019 23:16:30 GMT
I see that we're getting around 150 scala_2.10 downloads monthly. Is there
any other component which uses it? I would remove the module in 3.0 to not
break the compatibility.

--
Denis

On Thu, Jan 10, 2019 at 8:13 AM Nikolay Izhikov <nizhikov@apache.org> wrote:

> +1
>
> чт, 10 янв. 2019 г. в 19:09, Anton Vinogradov <av@apache.org>:
>
> > +1
> >
> > On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <akuznetsov@apache.org>
> > wrote:
> >
> > > +1 to drop support of Scala 2.10 in Ignite 2.8.
> > >
> > >
> > > On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <y.chief@gmail.com> wrote:
> > >
> > > > Hi Igniters,
> > > >
> > > > What do you think about the drop Scala 2.10 support?
> > > >
> > > > Currently, we support two versions of Scala - 2.10 and 2.11, I
> suggest
> > to
> > > > drop 2.10 and use only 2.11. Originally we have the old version of
> > Scala
> > > > for supporting old versions of Apache Spark.
> > > >
> > > > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark
> > released.
> > > > And current version if 2.4.0.
> > > >
> > > > Please share your opinion
> > > >
> > > > Best regards,
> > > > Yuriy Babak
> > > >
> > >
> > >
> > > --
> > > Alexey Kuznetsov
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message