ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Antonov <antonovserge...@gmail.com>
Subject Re: Options naming format in control.sh utility.
Date Fri, 11 Jan 2019 11:17:25 GMT
Sergey,

Not quite, I meant:
- boolean argument: *--word1-word2*
- single value argument  *--word1-word2 value*
- multiple values argument  *--word1-word2 value1,value2*

пт, 11 янв. 2019 г. в 14:12, Sergey Kozlov <skozlov@gridgain.com>:

> Sergey,
>
> Thanks for raising up the question.
>
> Did you mean following (?):
>  - boolean argument: *--word1-word2*
>  - single value argument  *--word1-word2=value*
>  - multiple values argument  *--word1-word2=value1  --word1-word2=value2*
>
>
> On Fri, Jan 11, 2019 at 2:05 PM Sergey Antonov <antonovsergey93@gmail.com>
> wrote:
>
> > Hi, Igniters!
> >
> > I want discuss and define options naming format in our utilities. I found
> > two naming styles in CommandHandler class  --excludeCaches and
> > --skip-zeros.
> > I think we should unify it. At this moment almost all options have second
> > naming format. I am offering rename --excludeCaches to --exclude-caches
> and
> > define format for future options. How about linux like format i.e.
> > --word1-word2?
> >
> > --
> > BR, Sergey Antonov
> >
>
>
> --
> Sergey Kozlov
> GridGain Systems
> www.gridgain.com
>


-- 
BR, Sergey Antonov

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message