ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Magda <dma...@apache.org>
Subject Re: Hibernate 5.3 merged!
Date Sat, 22 Dec 2018 07:13:54 GMT
Scott,

Apache 2.0 is just a license that is used by many projects outside of
Apache Software Foundation (ASF). Ignite is licensed under Apache 2.0 as
well and also a top-level project of ASF. All ASF projects cannot include
LGPL binaries:
https://www.apache.org/legal/resolved.html#category-x

Since Spring is not an ASF project, it's free to do whatever it wants.


--
Denis

On Fri, Dec 21, 2018 at 11:08 PM Scott Feldstein <scottf76@gmail.com> wrote:

> Hi Denis, Thanks for the response. spring is indeed Apache 2.0, see
>
> https://github.com/spring-projects/spring-framework/blob/master/src/docs/dist/license.txt
>
> Am I missing something?
>
>
> On Fri, Dec 21, 2018 at 22:37 Denis Magda <dmagda@apache.org> wrote:
>
> > Scott, Ilya,
> >
> > LGPL license is not compliant with Apache 2.0 and, thus, ASF project
> can't
> > include binaries of LGPL libs to ASF releases:
> > https://www.apache.org/legal/resolved.html#category-x
> >
> > Spring doesn't belong to ASF. It has its own rules and policies.
> >
> > --
> > Denis
> >
> >
> > On Thu, Dec 20, 2018 at 5:04 AM Ilya Kasnacheev <
> ilya.kasnacheev@gmail.com
> > >
> > wrote:
> >
> > > Hello!
> > >
> > > I don't think we can push it to public repositories in binary form. No
> > > change in that regard. As for Spring, I honestly have no idea. Maybe
> > > they're dual license?
> > >
> > > Regards,
> > > --
> > > Ilya Kasnacheev
> > >
> > >
> > > чт, 20 дек. 2018 г. в 01:32, Scott Feldstein <scottf76@gmail.com>:
> > >
> > > > Hi Ilya, that’s great news!
> > > >
> > > > What’s the likelihood of pushing the artifacts to a public maven repo
> > > along
> > > > with the other ignite artifacts? Are we constrained by the LGPL2
> > license?
> > > > If so, I wonder how spring works around that with their jpa impl?
> > > >
> > > > Scott
> > > > On Wed, Dec 19, 2018 at 09:03 Ilya Kasnacheev <
> > ilya.kasnacheev@gmail.com
> > > >
> > > > wrote:
> > > >
> > > > > Hello!
> > > > >
> > > > > I have just checked, and it looks like hibernate-5.3 module works
> > > > correctly
> > > > > with Hibernate 5.4.0.Final!
> > > > >
> > > > > It builds without errors and all tests pass. So maybe we can
> rebrand
> > it
> > > > as
> > > > > hibernate-5.3+ for the duration.
> > > > >
> > > > > Regards,
> > > > > --
> > > > > Ilya Kasnacheev
> > > > >
> > > > >
> > > > > ср, 19 дек. 2018 г. в 19:53, Павлухин Иван <vololo100@gmail.com>:
> > > > >
> > > > > > Good news!
> > > > > >
> > > > > > I also believe that a lot of users will be happy once it is
> > released.
> > > > > > Cheers!
> > > > > >
> > > > > > By the way, I noticed that the latest Hibernate version is 5.4.
> It
> > is
> > > > > > compatible with 5.3? Should it be somehow addressed by Ignite
> > > > > > developers?
> > > > > > ср, 19 дек. 2018 г. в 19:09, Ilya Kasnacheev <
> > > > ilya.kasnacheev@gmail.com
> > > > > >:
> > > > > > >
> > > > > > > Hello!
> > > > > > >
> > > > > > > I am proud to announce that I have just merged Hibernate
5.3
> > > module,
> > > > > > > courtesy Scott Feldstein.
> > > > > > >
> > > > > > > There were also important fixes which should make TC greener
> than
> > > > ever.
> > > > > > >
> > > > > > > Since this is a large patch there might be rough edges,
please
> > > notify
> > > > > me
> > > > > > if
> > > > > > > anything went awry, I will try to follow it up.
> > > > > > >
> > > > > > > Regards,
> > > > > > > --
> > > > > > > Ilya Kasnacheev
> > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Best regards,
> > > > > > Ivan Pavlukhin
> > > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message