ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Mashenkov (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-10187) Partition data can be lost after recover from WAL and no data were ever checkpointed.
Date Thu, 08 Nov 2018 12:15:01 GMT
Andrew Mashenkov created IGNITE-10187:
-----------------------------------------

             Summary: Partition data can be lost after recover from WAL and no data were ever
checkpointed.
                 Key: IGNITE-10187
                 URL: https://issues.apache.org/jira/browse/IGNITE-10187
             Project: Ignite
          Issue Type: Bug
          Components: persistence
            Reporter: Andrew Mashenkov


Steps to reproduce:
1. Start a node.

2. Disable checkpoints.

3. Put some data.

4. Flush WAL.

5. Restart node.

6. Next put hangs sporadically forever awaiting for next topology that will never happens.
The issue caused by ClusterTopologyException thrown due to partition MOVING state, however
it is expected partition to be in OWNING state.

The root cause is partition doesn't restore OWNING state after recover from WAL as it was
not checkpointed or contains no data when checkpoint occurs (partition was in initial state).

 

Seems, forcing checkpoint before disabling it resolves the issue. See CacheMvccTxFailoverTest.testSingleNodeTxMissedCommitNoCheckpoint().

 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message