ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stanislav Lukyanov <stanlukya...@gmail.com>
Subject RE: Abbreviation code-style requirement.
Date Tue, 16 Oct 2018 16:18:53 GMT
+ for all three.

I got used to seeing `cctx` and `ccfg` all over the place, but I remember the sorrow of seeing
all of that the first time.
I guess it’s nothing but a Stockholm syndrome now and I’m willing to cure myself :)


From: Eduard Shangareev
Sent: 16 октября 2018 г. 19:01
To: dev@ignite.apache.org
Subject: Abbreviation code-style requirement.


I want to discuss the appendix of our code-style:

First of all, there is no any mention that it is a mandatory part.

Secondly, some of them are very unintuitive and even misleading. For
example, cp. In current realization, it could mean not only copy but
checkpoint. Other example, proto... Would you get that it is protocol?

Thirdly, the recommended plugin highlights even parts of multiword names.
It provokes to used creepy names as
locCpPartitionsInProgress, needCpPartitions and so on.

So, I want to start a discussion for
1. revising the list of abbreviations,
2. stop using them for multi-word names,
3. and make them not mandatory at all (what it is actually already true,
because of no any mention in the main code-style article).

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message