ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Setrakyan <dsetrak...@apache.org>
Subject Re: Upgrading Ignite to JCache 1.1
Date Tue, 22 May 2018 23:58:45 GMT
Igniters,

It will be great if someone in the community would pick this up. The amount
of changes are minimal and many of them only have to do with clarifying the
documentation. However, removing JSR 107 license confusion in 1.1 would be
great for Ignite.

D.

On Tue, May 22, 2018 at 3:04 PM, Denis Magda <dmagda@apache.org> wrote:

> Here is a list of all changes:
> https://groups.google.com/forum/#!topic/jsr107/BC1qKqknzKU
>
> The primary argument for the migration is a license. JCache 1.0 is licensed
> by Oracle that causes legal issues for some of the users. Once we upgrade
> to JCache 1.1 the won't longer be a big deal.
>
> However, once we move to 1.1 we need to be sure that we comply with the
> updated specification.
>
> --
> Denis
>
> On Tue, May 22, 2018 at 5:20 AM, Dmitry Pavlov <dpavlov.spb@gmail.com>
> wrote:
>
> > Hi Denis,
> >
> > What was improved in JCache 1.1?
> >
> > Would it be useful for product to change supported spec. version?
> >
> > Sincerely,
> > Dmitriy Pavlov
> >
> > пн, 21 мая 2018 г. в 20:12, Denis Magda <dmagda@apache.org>:
> >
> > > Igniters,
> > >
> > > Eventually, JCache was relicensed to Apache 2.0 and released 1.1
> version:
> > > https://groups.google.com/forum/#!topic/jsr107/BC1qKqknzKU
> > >
> > > Is there anyone interested in upgrading Ignite to the new version for
> the
> > > next release?
> > > https://issues.apache.org/jira/browse/IGNITE-8548
> > >
> > > --
> > > Denis
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message