ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrey Mashenkov <andrey.mashen...@gmail.com>
Subject Fwd: Data Loss while upgrading custom jar from old jar in server and client nodes
Date Mon, 02 Apr 2018 13:15:31 GMT
Crossposting to dev.

Guys,
User use Ignite native persistence with CacheStore configured.
Seems, changing CacheStore requires cache recreation in his case to changes
can be applied.

Does anybody has idea how it can be fixed?

Do we allow to rewrite cache config in native store if it has minor changes
that will not cause issues? E.g. changing cacheStore factory or changing
number of backups?
Otherwise, I'd suggest to deprecate such configuration.


On Tue, Mar 27, 2018 at 4:18 PM, siva <siva.karna@bizruntime.com> wrote:

> Hi,
>
> Thanks for checking out issue. I think its not about IDE issue.
> Again same thing i have reproduce like bellow steps
>
> 1.run the program from IDE as client
> 2.copy jar to ignite libs folder and start the server
> 3.Then check previous message steps so that can able to reproduce the
> issue.
> https://www.youtube.com/watch?v=COQiu2gi8ag&t=43s
> <https://www.youtube.com/watch?v=COQiu2gi8ag&t=43s>
> I have attached the video link.Can you go through that video and check the
> issue.
>
>
> Thanks
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/
>



-- 
Best regards,
Andrey V. Mashenkov



-- 
Best regards,
Andrey V. Mashenkov

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message