ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Rakov <ivan.glu...@gmail.com>
Subject Re: Data Loss while upgrading custom jar from old jar in server and client nodes
Date Fri, 06 Apr 2018 11:12:51 GMT
By the way, ticket is marked with "newbie" label.
If there's anyone who wants to start contributing in Ignite, feel free 
to take this issue.

Best Regards,
Ivan Rakov

On 06.04.2018 14:06, Ivan Rakov wrote:
> Denis,
>
> I'm sure we can: https://issues.apache.org/jira/browse/IGNITE-8162
>
> Best Regards,
> Ivan Rakov
>
> On 05.04.2018 22:39, Denis Magda wrote:
>> Ivan,
>>
>> How can we facilitate the user here? Can we generate a meaningful 
>> exception
>> that explains how to tackle the issue?
>>
>> -- 
>> Denis
>>
>> On Thu, Apr 5, 2018 at 2:49 AM, Ivan Rakov <ivan.glukos@gmail.com> 
>> wrote:
>>
>>> Hi,
>>>
>>> Cache configuration is persisted in 
>>> db\{consistent-ID}\cache-{cache-name}\cache_data.dat
>>> file. It's just CacheConfiguration serialized by JDK marshaller.
>>> Try to delete this file and start cache with new configuration (with
>>> correct factory class names). All your data will persist as long as old
>>> ignite data is compatible with new configuration.
>>>
>>> Best Regards,
>>> Ivan Rakov
>>>
>>>
>>> On 04.04.2018 23:08, Denis Magda wrote:
>>>
>>>> Ivan R., Alex G., persistence experts,
>>>>
>>>> Please have a look at this question.
>>>>
>>>> -- 
>>>> Denis
>>>>
>>>> On Mon, Apr 2, 2018 at 6:15 AM, Andrey Mashenkov <
>>>> andrey.mashenkov@gmail.com
>>>>
>>>>> wrote:
>>>>> Crossposting to dev.
>>>>>
>>>>> Guys,
>>>>> User use Ignite native persistence with CacheStore configured.
>>>>> Seems, changing CacheStore requires cache recreation in his case to
>>>>> changes
>>>>> can be applied.
>>>>>
>>>>> Does anybody has idea how it can be fixed?
>>>>>
>>>>> Do we allow to rewrite cache config in native store if it has minor
>>>>> changes
>>>>> that will not cause issues? E.g. changing cacheStore factory or 
>>>>> changing
>>>>> number of backups?
>>>>> Otherwise, I'd suggest to deprecate such configuration.
>>>>>
>>>>>
>>>>> On Tue, Mar 27, 2018 at 4:18 PM, siva <siva.karna@bizruntime.com>

>>>>> wrote:
>>>>>
>>>>> Hi,
>>>>>> Thanks for checking out issue. I think its not about IDE issue.
>>>>>> Again same thing i have reproduce like bellow steps
>>>>>>
>>>>>> 1.run the program from IDE as client
>>>>>> 2.copy jar to ignite libs folder and start the server
>>>>>> 3.Then check previous message steps so that can able to reproduce

>>>>>> the
>>>>>> issue.
>>>>>> https://www.youtube.com/watch?v=COQiu2gi8ag&t=43s
>>>>>> <https://www.youtube.com/watch?v=COQiu2gi8ag&t=43s>
>>>>>> I have attached the video link.Can you go through that video and

>>>>>> check
>>>>>>
>>>>> the
>>>>>
>>>>>> issue.
>>>>>>
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>>
>>>>>>
>>>>>> -- 
>>>>>> Sent from: http://apache-ignite-users.70518.x6.nabble.com/
>>>>>>
>>>>>>
>>>>> -- 
>>>>> Best regards,
>>>>> Andrey V. Mashenkov
>>>>>
>>>>>
>>>>>
>>>>> -- 
>>>>> Best regards,
>>>>> Andrey V. Mashenkov
>>>>>
>>>>>
>


Mime
View raw message