ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrey Aleksandrov (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-8055) Sqline command !tables works incorrect for client node
Date Tue, 27 Mar 2018 10:34:00 GMT
Andrey Aleksandrov created IGNITE-8055:
------------------------------------------

             Summary: Sqline command !tables works incorrect for client node
                 Key: IGNITE-8055
                 URL: https://issues.apache.org/jira/browse/IGNITE-8055
             Project: Ignite
          Issue Type: Bug
          Components: jdbc
    Affects Versions: 2.4
            Reporter: Andrey Aleksandrov


For reproducing:

You should start one local server and one local client nodes and follow the instructions:


1)Connect to server node:

sqlline.bat --color=true --verbose=true -u jdbc:ignite:thin://127.0.0.1:10800

2)Create new table on server node:

CREATE TABLE City (id LONG PRIMARY KEY, name VARCHAR)WITH "template=replicated";

3)Check that table exists from server node:

!tables

On this step table should be shown in the response.

4)Connect to client node:

sqlline.bat --color=true --verbose=true -u jdbc:ignite:thin://127.0.0.1:10801

5)Check that table exists from server node:

!tables

*On this step there is no "city" table in the list.*

Next commands work from client node as well:
SELECT * FROM City
DROP TABLE City
 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message