ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Petr Ivanov <mr.wei...@gmail.com>
Subject Re: Scala 2.10 support
Date Wed, 10 Jan 2018 18:37:52 GMT
As much as I see, scala-2.10, spark-2.10 and visor-console-2.10 modules require scala 2.10
by dependency, which is not going to work any way (or at least without some hacky hack) with
Java 9.
Considering Java 9 to be strictly 2.4+ functionality — I guess it is more or less solid
approach in dropping support of deprecated (for some decent time) technologies in next releases
in favour of the newest ones where there is no other proper way of utilising them both.



> On 10 Jan 2018, at 18:55, Dmitriy Setrakyan <dsetrakyan@apache.org> wrote:
> 
> How much of an effort will be to support scala and spark 2.10?
> 
> On Wed, Jan 10, 2018 at 4:24 AM, vveider <mr.weider@gmail.com> wrote:
> 
>> Hi, Igniters!
>> 
>> 
>> While working on Java 9 support adaptation, came to a problem with scala
>> 2.10 and corresponding modules (scala-2.10, spark-2.10 and
>> visor-console-2.10) which will not compile under Java 9. As I see here [1]
>> scala 2.10 is already deprecated in spark 2.1.0 (and lately spark version
>> updated to 2.2.0 in master).
>> 
>> So, I'd like to propose scala-2.10, spark-2.10 and visor-console-2.10
>> modules for deletion in 2.4 release.
>> 
>> Support for scala 2.11.x (which also will not compile under Java 9) will be
>> maintained by maven profiles.
>> 
>> 
>> [1] http://spark.apache.org/docs/latest/
>> 
>> 
>> 
>> --
>> Sent from: http://apache-ignite-developers.2346864.n4.nabble.com/
>> 


Mime
View raw message