ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Chugunov (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-6583) Methods of rebalancing progress metrics must obey JavaBean naming conventions
Date Mon, 09 Oct 2017 13:24:02 GMT
Sergey Chugunov created IGNITE-6583:
---------------------------------------

             Summary: Methods of rebalancing progress metrics must obey JavaBean naming conventions
                 Key: IGNITE-6583
                 URL: https://issues.apache.org/jira/browse/IGNITE-6583
             Project: Ignite
          Issue Type: Bug
            Reporter: Sergey Chugunov
            Assignee: Sergey Chugunov
             Fix For: 2.4


h2. Notes
Getters for *rebalancingStartTime* and *estimateRebalancingFinishTime* metrics from *CacheMetrics*
interface don't follow JavaBean naming conventions; method names don't start with *get* prefix.

As a result metrics cannot be accessed via MXBean interface.

h2. Acceptance Criteria
# Methods *getRebalancingStartTime* and *getEstimateRebalancingFinishTime* are introduced
to *CacheMetrics* interface.
# Existing methods *rebalancingStartTime* and *estimateRebalancingFinishTime* are declared
as deprecated and will be deleted in future major release.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message