ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pavel Tupitsyn (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-6471) .NET: Flags should have plural names
Date Thu, 21 Sep 2017 16:10:00 GMT
Pavel Tupitsyn created IGNITE-6471:
--------------------------------------

             Summary: .NET: Flags should have plural names
                 Key: IGNITE-6471
                 URL: https://issues.apache.org/jira/browse/IGNITE-6471
             Project: Ignite
          Issue Type: Improvement
          Components: platforms
            Reporter: Pavel Tupitsyn
             Fix For: 3.0


{{[Flags]}} enums should have plural names.

For example, {{CachePeekMode}} should be renamed to {{CachePeekModes}}.
Also, {{int GetSize(params CachePeekMode[] modes)}} should be changed to {{int GetSize(CachePeekModes
modes)}}: flags can be combined with bitwise OR.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message