ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vyacheslav Daradur <daradu...@gmail.com>
Subject Testing of backward compatibility in Ignite
Date Wed, 12 Jul 2017 08:09:05 GMT
Hi Igniters.

There is a need to test backward compatibility with previous release within
a task[1].

As far as I understand: it needs to provide methods in the
Ignite-test-framework to start instance of specific version of Ignite.

I popose to add such api in the project, for example: "Ignite
startGrid(String ver)"

My main idea of implementation is:
1) download "jar" from the Maven repo
2) Wrap it in a custom classloader
3) Start instance via the classloader

I've created a ticket[2] for this task.

Guys, please, share your thoughts about described problem and ways of
implementation?

[1] BinaryMarshaller should write ints in "varint" encoding where it makes
sense <https://issues.apache.org/jira/browse/IGNITE-5097>
[2] Provide API to test compatibility with old releases
<https://issues.apache.org/jira/browse/IGNITE-5732>

-- 
Best Regards, Vyacheslav D.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message