ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergi Vladykin <sergi.vlady...@gmail.com>
Subject Re: What branch to use for Apache Ignite 2.0 development?
Date Wed, 07 Dec 2016 09:36:56 GMT
I think it is good idea to be able to continue releasing 1.X versions. It
may take quite some time to make Ignite 2.0 stable enough. Thus I'm for
keeping changes targeted exclusively to 2.0 in a separate branch for now.

Sergi

2016-12-07 12:23 GMT+03:00 Vladimir Ozerov <vozerov@gridgain.com>:

> Igniters,
>
> We are moving towards Apache Ignite 2.0. This release will contain lots of
> changes which break compilation on user side and change internal binary
> protocols. The question is - where to continue development of 2.0 features?
>
> We can do that in master branch. But what if we decide to release Apache
> Ignite 1.9 at some point? In this case we cannot use master branch because
> it will contain incompatible API changes. As alternative we can create
> separate branch for 2.0 and merge all breaking changes there. But it will
> complicate development process.
>
> Probably we can continue all development in *master*, and in case if we
> decide to release another 1.x release, then create branch from ignite-1.8
> tag and cherry-pick required fixes there.
>
> Please share your thoughts.
>
> Vladimir.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message