ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From afedotov <alexander.fedot...@gmail.com>
Subject Re: IgniteConfiguration.gridName is very confusing
Date Fri, 30 Dec 2016 10:53:24 GMT
Hello!

Looks like there has not been any activity on the issue since July, so I've
taken the issue.

I still have a concern regarding the naming: "instanceName" is quite vague
in some contexts like IgniteThread, SpringCacheManage etc. I would suggest
naming it like "gridInstanceName" or "nodeName". Also to make clear that the
name is effective locally "localNodeName" or "localGridInstanceName" could
be used.

Any considerations in this regard?


dsetrakyan wrote
> Biao, are you still working on this ticket or should someone else in the
> community pick it up?
> 
> On Fri, Aug 5, 2016 at 1:53 AM, Pavel Tupitsyn &lt;

> ptupitsyn@

> &gt; wrote:
> 
>> We keep getting a steady stream of users confused by gridName :)
>>
>> https://issues.apache.org/jira/browse/IGNITE-3207 seems to be abandoned,
>> should we unassign it?
>>
>> Pavel.
>>
>> On Fri, May 27, 2016 at 8:10 PM, Dmitriy Setrakyan &lt;

> dsetrakyan@

> &gt;
>> wrote:
>>
>> > Great! I think I like “instanceName” better, just in case if this name
>> will
>> > be provided for information purposes on other nodes.
>> >
>> > D.
>> >
>> > On Fri, May 27, 2016 at 2:29 AM, Pavel Tupitsyn &lt;

> ptupitsyn@

> &gt;
>> > wrote:
>> >
>> > > Done: https://issues.apache.org/jira/browse/IGNITE-3207
>> > >
>> > > I have stated "localInstanceName" there, because "instanceName" may
>> not
>> > be
>> > > clear enough.
>> > >
>> > > Pavel.
>> > >
>> > > On Fri, May 27, 2016 at 12:19 PM, Dmitriy Setrakyan <
>> > 

> dsetrakyan@

>> > > >
>> > > wrote:
>> > >
>> > > > I like the change, as long as we do not remove, but *deprecate* the
>> > > > gridName property and update all the documentation and examples.
>> > > >
>> > > > Pavel, can you please file a ticket?
>> > > >
>> > > > D.
>> > > >
>> > > > On Tue, May 24, 2016 at 1:56 AM, Pavel Tupitsyn <
>> > 

> ptupitsyn@

>>
>> > > > wrote:
>> > > >
>> > > > > Igniters,
>> > > > >
>> > > > > We have got a TON of questions on gridName property. Everyone
>> thinks
>> > > that
>> > > > > clusters are formed based on the gridName, that is, nodes with
>> the
>> > same
>> > > > > grid name will join one cluster, and nodes with a different name
>> will
>> > > be
>> > > > in
>> > > > > a separate cluster.
>> > > > >
>> > > > > I suggest to deprecate this property and add instanceName
>> instead.
>> > > > >
>> > > > > Thoughts?
>> > > > >
>> > > > > Pavel.
>> > > > >
>> > > >
>> > >
>> >
>>





-----
Kind regards,
Alexander
--
View this message in context: http://apache-ignite-developers.2346864.n4.nabble.com/IgniteConfiguration-gridName-is-very-confusing-tp9077p13451.html
Sent from the Apache Ignite Developers mailing list archive at Nabble.com.

Mime
View raw message