ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Cheng <kcheng....@gmail.com>
Subject Re: Caused by: java.lang.NoClassDefFoundError: org/h2/constant/SysProperties
Date Thu, 26 May 2016 09:07:12 GMT
I created a bug https://issues.apache.org/jira/browse/IGNITE-3204



Thanks,
kcheng

On Thu, May 26, 2016 at 4:55 PM, Ken Cheng <kcheng.mvp@gmail.com> wrote:

> Hi All,
>
> I ran into above issue. here is the error stack
>
>
> Caused by: java.lang.NoClassDefFoundError: org/h2/constant/SysProperties
> at
> org.apache.ignite.internal.processors.query.h2.IgniteH2Indexing.start(IgniteH2Indexing.java:1487)
> ~[ignite-indexing-1.6.0.jar:1.6.0]
> at
> org.apache.ignite.internal.processors.query.GridQueryProcessor.start(GridQueryProcessor.java:171)
> ~[ignite-core-1.6.0.jar:1.6.0]
> at
> org.apache.ignite.internal.IgniteKernal.startProcessor(IgniteKernal.java:1549)
> ~[ignite-core-1.6.0.jar:1.6.0]
> at org.apache.ignite.internal.IgniteKernal.start(IgniteKernal.java:869)
> ~[ignite-core-1.6.0.jar:1.6.0]
> at
> org.apache.ignite.internal.IgnitionEx$IgniteNamedInstance.start0(IgnitionEx.java:1736)
> ~[ignite-core-1.6.0.jar:1.6.0]
> at
> org.apache.ignite.internal.IgnitionEx$IgniteNamedInstance.start(IgnitionEx.java:1589)
> ~[ignite-core-1.6.0.jar:1.6.0]
> at org.apache.ignite.internal.IgnitionEx.start0(IgnitionEx.java:1042)
> ~[ignite-core-1.6.0.jar:1.6.0]
> at org.apache.ignite.internal.IgnitionEx.start(IgnitionEx.java:549)
> ~[ignite-core-1.6.0.jar:1.6.0]
> at org.apache.ignite.IgniteSpring.start(IgniteSpring.java:66)
> ~[ignite-spring-1.6.0.jar:1.6.0]
> at
> org.apache.ignite.IgniteSpringBean.afterPropertiesSet(IgniteSpringBean.java:128)
> ~[ignite-spring-1.6.0.jar:1.6.0]
> at
> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1637)
> ~[spring-beans-4.2.6.RELEASE.jar:4.2.6.RELEASE]
> at
> org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1574)
> ~[spring-beans-4.2.6.RELEASE.jar:4.2.6.RELEASE]
> ... 21 common frames omitted
> Caused by: java.lang.ClassNotFoundException: org.h2.constant.SysProperties
> at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
> ~[na:1.8.0_77]
> at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[na:1.8.0_77]
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
> ~[na:1.8.0_77]
> at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[na:1.8.0_77]
>
>
> I am using v1.6.0
>
> <dependency>
>     <groupId>org.apache.ignite</groupId>
>     <artifactId>ignite-core</artifactId>
>     <version>${ignite.version}</version>
> </dependency>
> <dependency>
>     <groupId>org.apache.ignite</groupId>
>     <artifactId>ignite-spring</artifactId>
>     <version>${ignite.version}</version>
> </dependency>
> <dependency>
>     <groupId>org.apache.ignite</groupId>
>     <artifactId>ignite-indexing</artifactId>
>     <version>${ignite.version}</version>
> </dependency>
>
>
> below is the dependency tree
>
> [INFO] +- org.apache.ignite:ignite-core:jar:1.6.0:compile
> [INFO] |  +- javax.cache:cache-api:jar:1.0.0:compile
> [INFO] |  \- org.gridgain:ignite-shmem:jar:1.0.0:compile
> [INFO] +- org.apache.ignite:ignite-spring:jar:1.6.0:compile
> [INFO] |  +- org.springframework:spring-core:jar:4.2.6.RELEASE:compile
> [INFO] |  +- org.springframework:spring-aop:jar:4.2.6.RELEASE:compile
> [INFO] |  |  \- aopalliance:aopalliance:jar:1.0:compile
> [INFO] |  +- org.springframework:spring-beans:jar:4.2.6.RELEASE:compile
> [INFO] |  +- org.springframework:spring-context:jar:4.2.6.RELEASE:compile
> [INFO] |  +- org.springframework:spring-expression:jar:4.2.6.RELEASE:compile
> [INFO] |  +- org.springframework:spring-tx:jar:4.2.6.RELEASE:compile
> [INFO] |  +- org.springframework:spring-jdbc:jar:4.2.6.RELEASE:compile
> [INFO] |  \- commons-logging:commons-logging:jar:1.1.1:compile
> [INFO] \- org.apache.ignite:ignite-indexing:jar:1.6.0:compile
> [INFO]    +- commons-codec:commons-codec:jar:1.6:compile
> [INFO]    +- org.apache.lucene:lucene-core:jar:3.5.0:compile
> [INFO]    \- com.h2database:h2:jar:1.4.191:compile
>
>
>
>
>
> I check there is no* org/h2/constant/SysProperties, on the contrary *
> *there is *org.h2.engine.SysProperties
>
>
> Seems it's a bug? if so, I am going log a jira.
>
>
>
> Thanks,
> kcheng
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message