ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Boudnik <...@apache.org>
Subject Re: 1.5.0.final is breaking packaging: osgi dependency is non-existent
Date Wed, 18 May 2016 00:12:08 GMT
On Mon, May 16, 2016 at 04:09AM, Andrey Kornev wrote:
> I'd love to elaborate, Konstantin, but I can't. I have no experience with
> the package management tools, neither yum nor rpm.

Understood, and that's ok. I am rather trying to understand where these could
possible be coming from.

> BTW, those Spring dependencies are optional, as far as I know. They are only
> required if Spring framework is used by the application (Spring XML
> configuration, for example).

Well, in case of HDFS and Spark accelerators Spring is used and packed all
along. Are you saying I would need to pick up some OSGI libs as well? If so,
where they could be found after the build is done? I wasn't able to spot them,
unfortunately.

Thanks!
  Cos

> > Date: Sun, 15 May 2016 10:20:57 -0400
> > From: cos@apache.org
> > To: dev@ignite.apache.org
> > Subject: Re: 1.5.0.final is breaking packaging: osgi dependency is non-existent
> > 
> > Thanks for checking out Andrey. Do you mind to elaborate on 'something'? The
> > way I see it, is that rpmbuilder performs certain checks to declare the
> > package dependencies, and the osgi once are popping up from somewhere. Which
> > wasn't the case before OSGI was added. Which lead me to believe that the issue
> > might be rooting from missing jars or something similar. Hence, my this email
> > thread.
> > 
> > Were my assumptions incorrect.
> > Thanks
> >   Cos
> > 
> > On Thu, May 05, 2016 at 04:39AM, Andrey Kornev wrote:
> > > Anton,
> > > 
> > > My first impression after having taken a look at bigtop's JIRA ticket is
> > > that the issue is not so much with OSGi per se, but rather it has something
> > > to do with Ignite's HDFS accelerator yum packaging.
> > > 
> > > Regards
> > > Andrey
> > > 
> > > > Date: Thu, 5 May 2016 13:55:26 +0300
> > > > Subject: Re: 1.5.0.final is breaking packaging: osgi dependency is non-existent
> > > > From: avinogradov@gridgain.com
> > > > To: dev@ignite.apache.org
> > > > 
> > > > Igniters,
> > > > 
> > > > Issue is critical for Bigtop project.
> > > > In case someone familiar with OSGI please have a look.
> > > > 
> > > > On Wed, May 4, 2016 at 11:15 AM, Anton Vinogradov <avinogradov@gridgain.com>
> > > > wrote:
> > > > 
> > > > > Roman, Raul,
> > > > >
> > > > > As far as I remember you're familiar with OSGI. Could you please
have a
> > > > > look at this?
> > > > >
> > > > > On Wed, May 4, 2016 at 6:09 AM, Konstantin Boudnik <cos@boudnik.org>
> > > > > wrote:
> > > > >
> > > > >> Hey guys
> > > > >>
> > > > >> For your information: adding osgi into the product is breaking
the
> > > > >> dependency matrix of the bigtop packages. For more info see
> > > > >>     https://issues.apache.org/jira/browse/BIGTOP-2421
> > > > >>
> > > > >> --
> > > > >> Take care,
> > > > >>         Cos
> > > > >> 2CAC 8312 4870 D885 8616  6115 220F 6980 1F27 E622
> > > > >> Cos' pubkey: http://people.apache.org/~cos/cos.asc
> > > > >>
> > > > >>          ---- Wisdom of the hour ----
> > > > >>
> > > > >>
> > > > >
> > >  		 	   		  
>  		 	   		  

Mime
View raw message