ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladimir Ozerov <voze...@gridgain.com>
Subject Re: MS VS 2010 for platforms
Date Wed, 13 Jan 2016 12:51:27 GMT
I would say that it is good that we cannot use 6.0 features even if we want
so. Otherwise users with earlier versions will not be able to build the
product from sources.
13 янв. 2016 г. 14:01 пользователь "Pavel Tupitsyn" <ptupitsyn@gridgain.com>
написал:

> Hi Sergey,
>
> You can build C++/.NET with any VS (2010+), you just have to click "upgrade
> VC++ compilers" on C++ projects. I use VS2015 Community, everything works
> just fine.
>
> Why do we support .NET 4 / VS2010? The lower the better. Some companies
> have weird software policies, so we have wider audience this way.
> .NET 4.5 does not offer any changes that are important for us.
>
> Another thing is C# version. You can use C# 6 with .NET 4, but, because we
> support VS2010, we have to stick to C# 4.
> This is unfortunate, because C# 6 does offer many nice improvements.
>
> On Wed, Jan 13, 2016 at 1:38 PM, Sergey Kozlov <skozlov@gridgain.com>
> wrote:
>
> > Hi Igniters
> >
> > I found that build of platforms (both .Ner and C++) requires Visual
> Studio
> > 2010 Professional.
> > Could someone explain:
> >  - Why we do not suggest to use Visual Studio Community?
> >  - VS 2010 seems a bit outdated.What's about VS 2015?
> >
> >
> > --
> > Sergey Kozlov
> >
>
>
>
> --
> --
> Pavel Tupitsyn
> GridGain Systems, Inc.
> www.gridgain.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message