ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Setrakyan <dsetrak...@apache.org>
Subject Re: keepBinaryInStore
Date Fri, 11 Dec 2015 07:49:03 GMT
On Thu, Dec 10, 2015 at 11:44 PM, Alexey Goncharuk <
alexey.goncharuk@gmail.com> wrote:

> If we do not want withKeepBinary() flag to affect the way objects are
> passed to a cache store, then I think current approach with a cache
> configuration flag is better than having a separate interface for store.
> With separate interfaces it is impossible to implement a 'universal' store
> which will properly handle both deserialized objects and binary objects,
> like our JDBC pojo store. Moreover, it is not clear to me what should
> happen if BinaryObjectStore is plugged and OptimizedMarshaller is set. This
> will force user to switch cache store implementation when marshaller
> changes, which does not sound right to me.

Agree, good catch! In this case we should rename it to be consistent with
out store configuration properties, e.g. setStoreKeepBinary(…)

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message