ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vasilisa Sidorova (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-1986) cpp: couldn't build cpp ignite-examples due to wrong parameters values in the project file
Date Mon, 23 Nov 2015 17:16:11 GMT
Vasilisa  Sidorova created IGNITE-1986:
------------------------------------------

             Summary: cpp: couldn't build cpp ignite-examples due to wrong parameters values
in the project file
                 Key: IGNITE-1986
                 URL: https://issues.apache.org/jira/browse/IGNITE-1986
             Project: Ignite
          Issue Type: Bug
    Affects Versions: 1.5
         Environment: Win7 64bit, MS Visual C++ 2010 Professional, Apache Ignite 1.5.0 build
#79
            Reporter: Vasilisa  Sidorova
            Priority: Critical
             Fix For: 1.5


---------------------------------------------
DESCRIPTION
---------------------------------------------
Couldn't build cpp ignite-examples due to wrong parameters values in the %IGNITE_HOME%\platforms\cpp\examples\project\vs\ignite-examples.vcxproj.
PlatformToolset is v120 but should be v100 (local fix for this issue works good)
---------------------------------------------
STEPS FOR REPRODUCE
---------------------------------------------
# Open and build %IGNITE_HOME%\platforms\cpp\project\vs\ignite.sln
# Open and build %IGNITE_HOME%\platforms\cpp\examples\project\vs\ignite-examples.sln
---------------------------------------------
ACTUAL RESULT
---------------------------------------------
Project doesn't built with error:

Error	1	error MSB8008: Specified platform toolset (v120) is not installed or invalid. Please
make sure that a supported PlatformToolset value is selected.	C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\x64\Microsoft.Cpp.x64.Targets
507	6	ignite-examples

---------------------------------------------
EXPECTED RESULT
---------------------------------------------
Solution built without any exceptions

--------------------------------------------
ADDITIONAL INFO
--------------------------------------------
Second error is wrong ToolsVersion in the same project file.
It's 12.0 and should be 4.0. Please, fix it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message