ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valentin Kulichenko <valentin.kuliche...@gmail.com>
Subject Re: 127.0.0.1 in VmIpFinder
Date Fri, 06 Nov 2015 00:51:32 GMT
Thanks, Andrey. What OS are you on? Can someone try this on Mac?

For me second node can't join because it can't connect to 127.0.0.1:47500
for some reason. I can't do this with telnet either, which is confusing
because the first one binds to 0.0.0.0 and therefore should be accessible
via all interfaces.

-Val

On Thu, Nov 5, 2015 at 4:45 PM, Andrey Gura <agura@gridgain.com> wrote:

> Val,
>
> I do it every day and do not have any problems. I tried it now on newest
> master branch and again - no problems.
>
> I just comment one line and uncomment other in config:
>
>                     <bean
>
> class="org.apache.ignite.spi.discovery.tcp.ipfinder.vm.TcpDiscoveryVmIpFinder">
>                     <!--<bean
>
> class="org.apache.ignite.spi.discovery.tcp.ipfinder.multicast.TcpDiscoveryMulticastIpFinder">-->
>                         <property name="addresses">
>                             <list>
>                                 <!-- In distributed environment, replace
> with actual host IP address. -->
>                                 <value>127.0.0.1:47500..47509</value>
>                             </list>
>                         </property>
>                     </bean>
>
>
>
> On Fri, Nov 6, 2015 at 2:27 AM, Valentin Kulichenko <
> valentin.kulichenko@gmail.com> wrote:
>
> > Igniters,
> >
> > I just tried to switch from multicast to VM IP finder in
> example-ignite.xml
> > and nodes stopped joining each other. If I start two servers, they both
> > start with order=1; if I start a server and then a client, the client
> never
> > joins.
> >
> > Can someone else try to do this and see if it's reproduced? For me this
> > behavior seems very confusing. And actually it means that our examples
> > don't work out of the box with disabled multicast.
> >
> > This user seems to have the same issue:
> >
> >
> http://apache-ignite-users.70518.x6.nabble.com/Unable-to-connect-to-Local-Node-Only-td1852.html
> >
> > -Val
> >
>
>
>
> --
> Andrey Gura
> GridGain Systems, Inc.
> www.gridgain.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message