ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Artem Shutak <ashu...@gridgain.com>
Subject Re: [Ignite-429] facing problem with node startup
Date Mon, 26 Oct 2015 13:42:33 GMT
Hi Chandresh,

As I understand you want to run cluster (more than one Ignite node) in one
JVM. In the case you should specify different names for nodes via
IgniteConfiguration.setName().

I strongly recommend you do not invent the wheel and extend your test class
from GridAbstarctTest which has methods to start/stop grids and do a lot
other really useful staff.

Also, you can look at any Ignite test where all your problems have been
already solved :)

-- Artem --

On Mon, Oct 26, 2015 at 11:03 AM, chandresh pancholi <
chandreshpancholi007@gmail.com> wrote:

> Hi igniters,
>
> i am starting two ignite node with same config
> file(Ignition.start("config/default-config.xml");).
> One node i am starting in onStart Method of test and another is in my
> streamer which close every time.
>
> So one node is always up and another is start-stop.
>
> By doing this i am getting exception saying
> org.apache.ignite.IgniteException:
> Default grid instance has already been started.
>
> Because of this exception i am not able to proceed further.
>
> Please help me out here.
>
>
> --
> Chandresh Pancholi
> Senior Software Engineer
> Flipkart.com
> Email-id:chandresh.pancholi@flipkart.com
> Contact:08951803660
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message