ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Kozlov <skoz...@gridgain.com>
Subject IGNITE-1195
Date Wed, 02 Sep 2015 18:58:54 GMT
Hi Igniters

I suppose that issue below won't be fixed in nearest release 1.4.

IGNITE-1195 Released Ignite version 1.3.0 does not build with
-Dhadoop.version=2.6.0 <https://issues.apache.org/jira/browse/IGNITE-1195>

Thus I think we need to update DEVNOTES.txt and add workaround for building
hadoop edition for particular hadoop version. It could be something like
that:

*Ignite Hadoop Accelerator Maven Build Instructions*
*============================================*
*mvn clean package -DskipTests -Dignite.edition=hadoop
[-Dhadoop.version=X.X.X]*

*Use 'hadoop.version' parameter to build Ignite against a specific Hadoop
version. Due known issue IGNITE-1195
(https://issues.apache.org/jira/browse/IGNITE-1195
<https://issues.apache.org/jira/browse/IGNITE-1195>) module yarn must be
excluded for this case:*

*1. For maven version prior 3.2.1 **comment
out <module>modules/yarn</module> in pom.xml and build.*

*2. For maven version 3.2.1 or newest:  *
*mvn clean package -DskipTests -Dignite.edition=hadoop
-Dhadoop.version=X.X.X -pl !module/yarn*

Thoughts? Objections?

-- 
Sergey Kozlov

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message