ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valentin Kulichenko <valentin.kuliche...@gmail.com>
Subject Re: Deprecate IgniteConfiguration.getGridName
Date Wed, 26 Aug 2015 18:08:13 GMT
+1 for 'instanceName'. 'nodeName' looks confusing as well - I would think
that it should be unique among all nodes.

-Val

On Wed, Aug 26, 2015 at 2:25 AM, Raul Kripalani <raul@evosent.com> wrote:

> Agree. The term grid to refer to a single node is very confusing.
> On 19 Aug 2015 08:58, "Semyon Boikov" <sboikov@gridgain.com> wrote:
>
> > In my opinion this propery just should be renamed to 'nodeName'.
> > Possibility to set node name is very useful in our tests. As I see
> > 'setNodeId' is already deprecated in IgniteConfiguration, how we will
> > distinguish nodes in our tests?
> >
> > On Tue, Aug 18, 2015 at 1:42 PM, Yakov Zhdanov <yzhdanov@apache.org>
> > wrote:
> >
> > > Guys,
> > >
> > > I am thinking of deprecating this property.
> > >
> > > 1. nodes with different grid names can discover each other and build a
> > > single topology. I heard that some of the users expected that there
> would
> > > be separate topologies
> > > 2. Locally started nodes can be accessed via their IDs through Ignition
> > > interface.
> > > 3. Internally gridName is used in components serialization and
> > > deserializaiton, but this is very unreliable and can be broken if
> > different
> > > names are configured within the same topology -
> > > https://issues.apache.org/jira/browse/IGNITE-10
> > >
> > > Thoughts?
> > >
> > > --Yakov
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message