ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergi Vladykin <sergi.vlady...@gmail.com>
Subject Re: Deprecate IgniteConfiguration.getGridName
Date Wed, 26 Aug 2015 09:21:10 GMT
I think `instanceName` is good enough (if it will have a proper javadoc).

Sergi

2015-08-26 9:24 GMT+03:00 Semyon Boikov <sboikov@gridgain.com>:

> We can add 'nodeName' on ClusterNode API, it is very easy to implement
> since node name is already stored in node attributes.
>
> On Wed, Aug 26, 2015 at 4:44 AM, Dmitriy Setrakyan <dsetrakyan@apache.org>
> wrote:
>
> > Although I share the sentiment that gridName is confusing, I think
> renaming
> > gridName to nodeName will be equally confusing. The "nodeName" property
> > sounds like something that should be on ClusterNode API, which is not the
> > case.
> >
> > If we rename if in one of the future versions, I think instanceName would
> > be a better option, no?
> >
> > D.
> >
> > On Wed, Aug 19, 2015 at 1:36 PM, Yakov Zhdanov <yzhdanov@apache.org>
> > wrote:
> >
> > > I tend to agree with Semyon. This is not a grid name, but the name of
> the
> > > local Ignite instance as an entry point to the grid. And this name is
> > used
> > > to conveniently get local Ignite instance: Ignite ignite =
> > > Ignition.ignite(name);
> > >
> > > It's usage in internal marshalling should stop.
> > >
> > > Any other opinions?
> > >
> > > --Yakov
> > >
> > > 2015-08-19 11:04 GMT+03:00 Alexey Kuznetsov <akuznetsov@gridgain.com>:
> > >
> > > > Semen, it is possible to distinguish nodes via attributes (put some
> > > marker
> > > > to node attributes) ?
> > > >
> > > > On Wed, Aug 19, 2015 at 2:57 PM, Semyon Boikov <sboikov@gridgain.com
> >
> > > > wrote:
> > > >
> > > > > In my opinion this propery just should be renamed to 'nodeName'.
> > > > > Possibility to set node name is very useful in our tests. As I see
> > > > > 'setNodeId' is already deprecated in IgniteConfiguration, how we
> will
> > > > > distinguish nodes in our tests?
> > > > >
> > > > > On Tue, Aug 18, 2015 at 1:42 PM, Yakov Zhdanov <
> yzhdanov@apache.org>
> > > > > wrote:
> > > > >
> > > > > > Guys,
> > > > > >
> > > > > > I am thinking of deprecating this property.
> > > > > >
> > > > > > 1. nodes with different grid names can discover each other and
> > build
> > > a
> > > > > > single topology. I heard that some of the users expected that
> there
> > > > would
> > > > > > be separate topologies
> > > > > > 2. Locally started nodes can be accessed via their IDs through
> > > Ignition
> > > > > > interface.
> > > > > > 3. Internally gridName is used in components serialization and
> > > > > > deserializaiton, but this is very unreliable and can be broken
if
> > > > > different
> > > > > > names are configured within the same topology -
> > > > > > https://issues.apache.org/jira/browse/IGNITE-10
> > > > > >
> > > > > > Thoughts?
> > > > > >
> > > > > > --Yakov
> > > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > Alexey Kuznetsov
> > > > GridGain Systems
> > > > www.gridgain.com
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message