ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anton Vinogradov <avinogra...@gridgain.com>
Subject Re: Build errors on bleeding edge
Date Tue, 02 Jun 2015 11:04:51 GMT
Atri,

"Connection reset" means you have connection problems.
In case you can't fix them, run builds until you get "Build succes" or
error without "Connection reset" text in it.

On Tue, Jun 2, 2015 at 1:54 PM, Atri Sharma <atri.jiit@gmail.com> wrote:

> Anton,
>
> I tried running again and got a different error:
>
> Failed to execute goal on project ignite-cloud: Could not resolve
> dependencies for project org.apache.ignite:ignite-cloud:jar:1.1.1-SNAPSHOT:
> Failed to collect dependencies for
> [org.apache.ignite:ignite-core:jar:1.1.1-SNAPSHOT (compile),
> org.apache.jclouds:jclouds-allcompute:jar:1.9.0 (compile),
> org.apache.jclouds.labs:google-compute-engine:jar:1.9.0 (compile),
> org.apache.jclouds.labs:docker:jar:1.9.0 (compile),
> org.apache.jclouds.provider:cloudsigma-zrh:jar:1.8.0 (compile),
> org.apache.ignite:ignite-core:jar:tests:1.1.1-SNAPSHOT (test),
> org.springframework:spring-beans:jar:4.1.0.RELEASE (test),
> log4j:log4j:jar:1.2.17 (test),
> org.springframework:spring-context:jar:4.1.0.RELEASE (test),
> org.springframework:spring-core:jar:4.1.0.RELEASE (test),
> junit:junit:jar:4.11 (test)]: Failed to read artifact descriptor for
> org.bouncycastle:bcpkix-jdk15on:jar:1.50: Could not transfer artifact
> org.bouncycastle:bcpkix-jdk15on:pom:1.50 from/to central (
> http://repo.maven.apache.org/maven2): Connection reset -> [Help 1]
>
>
> On Tue, Jun 2, 2015 at 3:01 PM, Anton Vinogradov <avinogradov@gridgain.com
> >
> wrote:
>
> > Atri,
> >
> > Seem you still have problem with connection to public maven repositories.
> > Do you have same error at each attempt?
> >
> > On Tue, Jun 2, 2015 at 12:26 PM, Atri Sharma <atri.jiit@gmail.com>
> wrote:
> >
> > > Thanks for pointing that out.
> > >
> > > I did that and got this:
> > >
> > > [ERROR] Failed to execute goal on project ignite-core: Could not
> resolve
> > > dependencies for project
> > org.apache.ignite:ignite-core:jar:1.1.1-SNAPSHOT:
> > > The following artifacts could not be resolved:
> mx4j:mx4j-tools:jar:3.0.1,
> > > commons-dbcp:commons-dbcp:jar:1.4: Could not transfer artifact
> > > mx4j:mx4j-tools:jar:3.0.1 from/to central (
> > > http://repo.maven.apache.org/maven2): Connection reset -> [Help 1]
> > >
> > >
> > > On Tue, Jun 2, 2015 at 2:50 PM, Anton Vinogradov <
> > avinogradov@gridgain.com
> > > >
> > > wrote:
> > >
> > > > Atri,
> > > >
> > > > Ignite 1.0.0 have compatibility issues with openjdk.
> > > > Please chekout from refs/heads/ignite-sprint-5 and try to build
> again.
> > > >
> > > > On Tue, Jun 2, 2015 at 12:13 PM, Atri Sharma <atri.jiit@gmail.com>
> > > wrote:
> > > >
> > > > >  mvn -v
> > > > > Apache Maven 3.0.4
> > > > > Maven home: /usr/share/maven
> > > > > Java version: 1.7.0_79, vendor: Oracle Corporation
> > > > > Java home: /usr/lib/jvm/java-7-openjdk-amd64/jre
> > > > > Default locale: en_IN, platform encoding: UTF-8
> > > > > OS name: "linux", version: "3.2.0-44-generic", arch: "amd64",
> family:
> > > > > "unix"
> > > > >
> > > > >
> > > > > Yes, I used mvn clean package -DskipTests
> > > > >
> > > > > On Tue, Jun 2, 2015 at 2:42 PM, Anton Vinogradov <
> > > > avinogradov@gridgain.com
> > > > > >
> > > > > wrote:
> > > > >
> > > > > > Atri,
> > > > > >
> > > > > > Please execute:
> > > > > > mvn -v
> > > > > > and reply with results.
> > > > > >
> > > > > > Also, please specify what command do use use to start build.
> > > > > > is it "mvn clean package -DskipTests"?
> > > > > > Seems you are using incompatible set of profiles.
> > > > > >
> > > > > > On Tue, Jun 2, 2015 at 10:05 AM, Atri Sharma <
> atri.jiit@gmail.com>
> > > > > wrote:
> > > > > >
> > > > > > > Anton,
> > > > > > >
> > > > > > > Thanks for your response. I tried setting JAVA_HOME to
JDK7
> just
> > > > before
> > > > > > > building but got this error:
> > > > > > >
> > > > > > > [ERROR] Failed to execute goal on project ignite-schema-import:
> > > Could
> > > > > not
> > > > > > > resolve dependencies for project
> > > > > > > org.apache.ignite:ignite-schema-import:jar:1.0.0: Could
not
> find
> > > > > artifact
> > > > > > > javafx:jfxrt:jar:1.7.0_79 at specified path
> > > > > > > /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/jfxrt.jar ->
[Help 1]
> > > > > > >
> > > > > > > Please advice. This is hampering my development
> > > > > > >
> > > > > > > On Mon, Jun 1, 2015 at 9:26 PM, Anton Vinogradov <
> > > > > > avinogradov@gridgain.com
> > > > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > > > Atri,
> > > > > > > >
> > > > > > > > Seems you have you have network problems during build.
> > > > > > > > We have internal TeamCity server which compiles Apache
Ignite
> > on
> > > > each
> > > > > > > > commit using JDK 7 and 8.
> > > > > > > > And I see no maven specific errors at these builds
logs.
> > > > > > > >
> > > > > > > > Do you have the same error message each time you running
> build?
> > > > > > > >
> > > > > > > > Marko,
> > > > > > > >
> > > > > > > > Could you please specify what error did you get?
> > > > > > > >
> > > > > > > > Also, please specify which update of JDK8 do you use.
> > > > > > > >
> > > > > > > > On Mon, Jun 1, 2015 at 4:35 PM, Atri Sharma <
> > atri.jiit@gmail.com
> > > >
> > > > > > wrote:
> > > > > > > >
> > > > > > > > > Marko,
> > > > > > > > >
> > > > > > > > > The link opens fine for me. Dont know what the
issue is :(
> > > > > > > > >
> > > > > > > > > On Mon, Jun 1, 2015 at 3:37 PM, Marko Jevtic
<
> > > > > markojevtic@gmail.com>
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > > Atri,
> > > > > > > > > >
> > > > > > > > > > You seem to have a network problem with
maven connecting
> to
> > > the
> > > > > > > central
> > > > > > > > > > repository. Are you running behind some
proxy? Or
> anything
> > > else
> > > > > in
> > > > > > > your
> > > > > > > > > > network that could cause connection reset?
> > > > > > > > > >
> > > > > > > > > > Try opening http://repo.maven.apache.org/maven2
<
> > > > > > > > > > http://repo.maven.apache.org/maven2>
if you are not
> behind
> > > the
> > > > > > > proxy.
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > > On Jun 1, 2015, at 12:02 PM, Atri Sharma
<
> > > > atri.jiit@gmail.com>
> > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > I tried doing this and then got this
error:
> > > > > > > > > > >
> > > > > > > > > > > [ERROR] Failed to execute goal on project
> > ignite-rest-http:
> > > > > Could
> > > > > > > not
> > > > > > > > > > > resolve dependencies for project
> > > > > > > > > > > org.apache.ignite:ignite-rest-http:jar:1.0.0:
Could not
> > > > > transfer
> > > > > > > > > artifact
> > > > > > > > > > > net.sf.ezmorph:ezmorph:jar:1.0.6 from/to
central (
> > > > > > > > > > > http://repo.maven.apache.org/maven2):
Connection reset
> > ->
> > > > > [Help
> > > > > > 1]
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > On Mon, Jun 1, 2015 at 2:55 PM, Atri
Sharma <
> > > > > atri.jiit@gmail.com
> > > > > > >
> > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > >> The solution is to get JAVA_HOME
to point to JDK7?
> > > > > > > > > > >> On 1 Jun 2015 14:35, "Dmitriy Setrakyan"
<
> > > > > dsetrakyan@apache.org
> > > > > > >
> > > > > > > > > wrote:
> > > > > > > > > > >>
> > > > > > > > > > >>> I got the same errors, until
I switched to JDK 7. Is
> > > there
> > > > a
> > > > > > > reason
> > > > > > > > > > why we
> > > > > > > > > > >>> don't allow build on JDK8?
> > > > > > > > > > >>>
> > > > > > > > > > >>> D.
> > > > > > > > > > >>>
> > > > > > > > > > >>> On Mon, Jun 1, 2015 at 1:41
AM, Atri Sharma <
> > > > > > atri.jiit@gmail.com
> > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > > >>>
> > > > > > > > > > >>>> Hi,
> > > > > > > > > > >>>>
> > > > > > > > > > >>>> I git pulled to my existing
repo today and got the
> > > > following
> > > > > > > > errors
> > > > > > > > > on
> > > > > > > > > > >>>> building again:
> > > > > > > > > > >>>>
> > > > > > > > > > >>>>
> > > > > > > > > > >>>> [ERROR] Plugin
> > > > > > > org.apache.maven.plugins:maven-enforcer-plugin:1.4
> > > > > > > > or
> > > > > > > > > > >>> one of
> > > > > > > > > > >>>> its dependencies could
not be resolved: Failed to
> read
> > > > > > artifact
> > > > > > > > > > >>> descriptor
> > > > > > > > > > >>>> for
> > > > org.apache.maven.plugins:maven-enforcer-plugin:jar:1.4:
> > > > > > > Could
> > > > > > > > > not
> > > > > > > > > > >>>> transfer artifact
> > > > > > > > > > org.apache.maven.plugins:maven-enforcer-plugin:pom:1.4
> > > > > > > > > > >>>> from/to central (
> http://repo.maven.apache.org/maven2
> > ):
> > > > > > > Connection
> > > > > > > > > > >>> reset ->
> > > > > > > > > > >>>> [Help 1]
> > > > > > > > > > >>>>
> > > > > > > > > > >>>>
> > > > > > > > > > >>>> Some problem with my configuration?
> > > > > > > > > > >>>> --
> > > > > > > > > > >>>> Regards,
> > > > > > > > > > >>>>
> > > > > > > > > > >>>> Atri
> > > > > > > > > > >>>> *l'apprenant*
> > > > > > > > > > >>>>
> > > > > > > > > > >>>
> > > > > > > > > > >>
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > --
> > > > > > > > > > > Regards,
> > > > > > > > > > >
> > > > > > > > > > > Atri
> > > > > > > > > > > *l'apprenant*
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Regards,
> > > > > > > > >
> > > > > > > > > Atri
> > > > > > > > > *l'apprenant*
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Regards,
> > > > > > >
> > > > > > > Atri
> > > > > > > *l'apprenant*
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Regards,
> > > > >
> > > > > Atri
> > > > > *l'apprenant*
> > > > >
> > > >
> > >
> > >
> > >
> > > --
> > > Regards,
> > >
> > > Atri
> > > *l'apprenant*
> > >
> >
>
>
>
> --
> Regards,
>
> Atri
> *l'apprenant*
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message