ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergi Vladykin <sergi.vlady...@gmail.com>
Subject Re: Ignite and Scala 2.10/2.11
Date Mon, 01 Jun 2015 14:52:47 GMT
How hard will it be to support both versions of Scala in the project?

Also what do you this about GridGain's Visor, will it work with both
versions? I don't think we should break known third party software based on
Apache Ignite.

Sergi

2015-06-01 13:50 GMT+03:00 Alexey Kuznetsov <akuznetsov@gridgain.com>:

> Igniters,
>
> We have an open issue IGNITE-389: Integration with Spark: IgniteRDD.
> And Spark uses Scala 2.10 (could be build with Scala 2.11).
> Ignite uses Scala 2.11.
>
> So we need to some how solve this situation.
> After some investigations (take a look in Spark pom) I found how to build
> Ignite with Scala 2.10 and Scala 2.11.
>
> But there two open questions:
>  #1. What should be default version of Scala? I think Scala 2.10 (for
> compatibility with Spark out of the box).
>
>  #2. We need to upload on maven two versions of modules that depend on
> Scala? How we should name them? I think names should be like:
> ignite-scalar-${scala.version}.
>
> Any comments?
>
>
>
> --
> Alexey Kuznetsov
> GridGain Systems
> www.gridgain.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message