ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@apache.org>
Subject Re: Ignite and Scala 2.10/2.11
Date Tue, 02 Jun 2015 09:52:50 GMT
On 01.06.2015 18:06, Dmitriy Setrakyan wrote:
> On Mon, Jun 1, 2015 at 9:01 AM, Nikita Ivanov <nivanov30@gmail.com> wrote:
>
>> Generally, I'd vote for 2.11 not because of any language features but
>> because of stability (and tooling around). 2.11 is very stable (comparing
>> to 2.10).
>>
> If we go with 2.11, how do we make it work with Spark which runs on Scala
> 2.10?

Teach Spark to use Scala 2.11, of course.

I find it inconceivable that minor Scala versions are incompatible to
this extent. Looks like a major fail to me ... but not that uncommon,
notice that Ruby has the same lack of backward compatibility.

-- Brane

Mime
View raw message