ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ognen Duzlevski <ognen.duzlev...@gmail.com>
Subject Joining an ignite cluster (via ignite.sh) delay
Date Sat, 18 Apr 2015 20:27:39 GMT
Hello,

I have noticed that with 1.0.0-incubating there is somewhat of a delay with
"joining" an ignite cluster. I have 6 EC2 instances - I start ignite.sh
examples/configs/example-ignite.sh & and then move on the next instance.
The same command on the next instance takes about 5-10 seconds before it
returns and each additional instance seems to take even longer. Anyone else
notice this?

What ports do I need to have open on the instances so that they can all
talk to each other?

I have these so far:
ACCEPT     udp  --  anywhere             anywhere            udp dpt:31100
ACCEPT     udp  --  anywhere             anywhere            udp dpt:47400
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:47500
ACCEPT     tcp  --  anywhere             anywhere            tcp dpt:47100

Anything else necessary? Or is the above too much - some of them can be
closed - which ones?

Finally,

I get this when I run ingnite.sh (1.0.0-incubating):
[15:22:31] Topology snapshot [ver=3, nodes=3, CPUs=24, heap=3.0GB]
[15:22:32] New version is available at ignite.incubator.apache.org: 1.0.2

Where is 1.0.2 available for downloads? All I see is 1.0.0-incubating.

Thanks!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message