ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Setrakyan <dsetrak...@gridgain.com>
Subject Re: Ignite component class names.
Date Fri, 03 Apr 2015 14:07:30 GMT
Agree.

On Fri, Apr 3, 2015 at 5:24 AM, Vladimir Ozerov <vozerov@gridgain.com>
wrote:

> Hi,
>
> We removed "Grid" prefix from all public API in Ignite. However, we still
> have odd namings in internal classes which can be used by plugin
> developers. E.g.:
>
> DR:
> GridCacheDrManager - DR manager interaface;
> GridOsCacheDrManager - Ignite implementation of DR manager;
>
> Cache objects:
> IgniteCacheObjectProcessor - interface;
> IgniteCacheObjectProcessorImpl - implementation.
>
> It seems to me that we should ensure that all components which can
> potentially be exposed to plugin developers should have consistent namings
> as well. E.g.:
> GridCacheDrManager -> CacheDrManager
> GridOsCacheDrManager -> IgniteCacheDrManager (other implementors could
> follow [Vendor]CacheDrManager pattern).
>
> If we do not do that now, we will have to preserve these inconsistent names
> because their refactoring will brake third-party plugins.
>
> Thoughts?
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message