ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexey Kuznetsov <akuznet...@gridgain.com>
Subject Re: requiring java 1.7
Date Tue, 31 Mar 2015 03:22:26 GMT
Build procedure was significantly modified in sprint-3.
If we want to try to compile sprint-2 with JDK 8 we will need to modify
pom.xml
As of we released, we cannot change anything without restart release voting.
Should I try to compile sprint-2 with JDK 8?

On Tue, Mar 31, 2015 at 9:37 AM, Dmitriy Setrakyan <dsetrakyan@apache.org>
wrote:

> On Mon, Mar 30, 2015 at 7:27 PM, Alexey Kuznetsov <akuznetsov@gridgain.com
> >
> wrote:
>
> > Dmitry, I've just tried to compile ignite-sprint-3 with Idea and
> comandline
> > maven under JDK 8.40 - all compiled without errors.
> >
>
> Can you please try the sprint-2? This is the one that just got released.
>
>
> >
> > On Tue, Mar 31, 2015 at 7:37 AM, Dmitriy Setrakyan <
> dsetrakyan@apache.org>
> > wrote:
> >
> > > Alexey K,
> > >
> > > The code does not compile under Java 8. I think we should either fix it
> > to
> > > compile or add Java 7 restriction.
> > >
> > > D.
> > >
> > > On Mon, Mar 30, 2015 at 5:24 PM, Alexey Kuznetsov <
> > akuznetsov@gridgain.com
> > > >
> > > wrote:
> > >
> > > > I thought that we enforce JDK 7 because of our java8 backported
> > classes.
> > > > But now we reworked code to solve this issue.
> > > > May be we do not need any more such restriction?
> > > >
> > > > On Tue, Mar 31, 2015 at 6:31 AM, Konstantin Boudnik <cos@apache.org>
> > > > wrote:
> > > >
> > > > > On Mon, Mar 30, 2015 at 04:26PM, Dmitriy Setrakyan wrote:
> > > > > > On Mon, Mar 30, 2015 at 4:10 PM, Konstantin Boudnik <
> > cos@apache.org>
> > > > > wrote:
> > > > > >
> > > > > > > Shouldn't we be able to compile with Java8 as well?
> > > > > > >
> > > > > >
> > > > > > Ideally, yes. But from what I heard, it requires additional
work.
> > > > >
> > > > > Curious. The forward transition should be straigh-forward, but I
> > guess
> > > it
> > > > > is
> > > > > possible to create some forward-incompatible code. If that's the
> case
> > > > then
> > > > > an
> > > > > enforcer check for 1.7 would be a good idea.
> > > > >
> > > > > > > On Mon, Mar 30, 2015 at 04:08PM, Dmitriy Setrakyan wrote:
> > > > > > > > Guys,
> > > > > > > >
> > > > > > > > I thought we added a requirement to make sure that
maven
> build
> > > > > requires
> > > > > > > JDK
> > > > > > > > 1.7. But if I build with JDK 1.8 I get only compilation
> errors
> > > > > without
> > > > > > > any
> > > > > > > > explanation why.
> > > > > > > >
> > > > > > > > Can someone comment on that, please?
> > > > > > > >
> > > > > > > > D.
> > > > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > Alexey Kuznetsov
> > > > GridGain Systems
> > > > www.gridgain.com
> > > >
> > >
> >
> >
> >
> > --
> > Alexey Kuznetsov
> > GridGain Systems
> > www.gridgain.com
> >
>



-- 
Alexey Kuznetsov
GridGain Systems
www.gridgain.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message