ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Setrakyan <dsetrak...@apache.org>
Subject Re: Imports
Date Sat, 07 Feb 2015 10:45:12 GMT
I agree with Yakov. We should always specify either Map.Entry or
Cache.Entry. Gets very confusing otherwise.

D.

On Sat, Feb 7, 2015 at 12:52 AM, Yakov Zhdanov <yzhdanov@apache.org> wrote:

> Guys,
>
> I want everyone to avoid imports like this
>
> import static java.util.Map.*;
>
> We have javax.cache.Cache.Entry. So, we will come to a point when in some
> part of sources Map.Entry and Entry [cache] will be used, and Cache.Entry
> and Entry [map] will be used in other parts. This will cause a lot of
> inconveniences.
>
> Thoughts?
>
> --Yakov
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message