ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Setrakyan <dsetrak...@apache.org>
Subject Re: IgfsHadoopFileSystemWrapper naming.
Date Thu, 26 Feb 2015 13:39:12 GMT

I agree that it smells. Can you explain again the difference between
IgfsHadoopFileSystem and IgfsHadoopFileSystemWrapper?


On Thu, Feb 26, 2015 at 5:21 AM, Vladimir Ozerov <vozerov@gridgain.com>

> HI,
> Currently we have IgfsHadoopFileSystemWrapper class whose sole purpose is
> to instantiate Hadoop FileSystem and delegate Igfs calls to it. We use this
> class to configure secondary Hadoop file system for Igfs.
> It seems to me that "Wrapper" is wrong suffix here from user perspective,
> as this is not a wrapper, but a functional unit which user uses in
> configuration. It does not "wraps" anything from user point of view.
> Furthermore, we do have public classes IgfsHadoopFileSystem which have no
> realtion to IgfsHadoopFileSystemWrapper, what will also confuse users.
> We need to think about another class name here. May be
> "IgfsHadoopFileSystemDelegator" or something like this?
> Any thoughts?
> Vladimir.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message