ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Morearty, Brian" <Brian_Morea...@intuit.com>
Subject RE: Ibator 1.2.2 Eclipse jars not published
Date Sat, 13 Mar 2010 02:57:49 GMT
I got it working.  

In case anyone else has this problem: I didn't know I had to update the build.properties file
to set some variables in there to match my local machine configuration.

I also had to update site.xml.  This is what I ended up with:

<?xml version="1.0" encoding="UTF-8"?>
<site>
   <feature url="features/org.apache.ibatis.ibator_1.2.0.jar" id="org.apache.ibatis.ibator"
version="1.2.0">
      <category name="Ibator Version 1.2"/>
   </feature>
   <feature url="features/org.apache.ibatis.ibator_1.2.1.jar" id="org.apache.ibatis.ibator"
version="1.2.1">
      <category name="Ibator Version 1.2"/>
   </feature>
   <feature url="features/org.apache.ibatis.ibator_1.2.2.jar" id="org.apache.ibatis.ibator"
version="1.2.2">
      <category name="Ibator Version 1.2"/>
   </feature>
   <feature url="features/org.apache.ibatis.ibator.source_1.2.2.jar" id="org.apache.ibatis.ibator.source"
version="1.2.2">
      <category name="Ibator Source Version 1.2"/>
   </feature>
   <category-def name="Ibator Version 1.2" label="Ibator Version 1.2">
      <description>
         Versions of the Ibator featured based on Ibator version 1.2 and Eclipse version 3.4.1
      </description>
   </category-def>
   <category-def name="Ibator Source Version 1.2" label="Ibator Version 1.2">
      <description>
         Versions of the Ibator Source featured based on Ibator version 1.2 and Eclipse version
3.4.1
      </description>
   </category-def>
</site>



-----Original Message-----
From: Morearty, Brian [mailto:Brian_Morearty@intuit.com] 
Sent: Friday, March 12, 2010 4:37 PM
To: user-java@ibatis.apache.org
Subject: RE: Ibator 1.2.2 Eclipse jars not published

Cool, that helps.  Do you mean right-click build.xml in the build project and choose "Run
As -> Ant Build"?

When I do that I get a bunch of errors, even though the Eclipse syntax highlighter doesn't
show errors.  The errors indicate that the compiler can't find Ant.  Things like:

[javadoc] C:\Code\ibator\core\ibator-core\src\main\java\org\apache\ibatis\ibator\ant\AntProgressCallback.java:20:
package org.apache.tools.ant does not exist
  [javadoc] import org.apache.tools.ant.Project;
  [javadoc]                             ^
  [javadoc] C:\Code\ibator\core\ibator-core\src\main\java\org\apache\ibatis\ibator\ant\AntProgressCallback.java:21:
package org.apache.tools.ant does not exist
  [javadoc] import org.apache.tools.ant.Task;
  [javadoc]                             ^
  [javadoc] C:\Code\ibator\core\ibator-core\src\main\java\org\apache\ibatis\ibator\ant\AntProgressCallback.java:31:
cannot find symbol
  [javadoc] symbol  : class Task
  [javadoc] location: class org.apache.ibatis.ibator.ant.AntProgressCallback
  [javadoc]     private Task task;
  [javadoc]             ^

And so forth.

Brian



-----Original Message-----
From: Jeff Butler [mailto:jeffgbutler@gmail.com] 
Sent: Friday, March 12, 2010 12:35 PM
To: user-java@ibatis.apache.org
Subject: Re: Ibator 1.2.2 Eclipse jars not published

Run the build.xml file in the build project.

Jeff Butler


On 3/12/10, Morearty, Brian <Brian_Morearty@intuit.com> wrote:
> Hmm, I must have done something wrong.  As instructed on the build page I
> loaded the projects into Eclipse and waited for the build to complete.  But
> I don't have a \Temp\ibator.build\I.TestBuild directory.
>
> (When you wrote \Temp did you mean at the root of the drive?  I checked
> there, as well as under my Ibator source tree.)
>
> What is the name of the file I should be looking for to unzip?
>
> I do see an "org.apache.ibatis.ibator.build" project that wasn't mentioned
> in the build instructions.  This is the closest I have to an "ibator.build"
> folder.  But the only things in it are build.properties, build.xml,
> .project, and a .svn folder.
>
> There were some "Plug-in Problems" in the Eclipse Problems pane.  I don't
> know if these are relevant.
>
> Description
>   Resource         Path                                      Location
> Type
> Feature reference 'org.apache.ibatis.ibator.source' cannot be resolved
>  feature.xml       /org.apache.ibatis.ibator                 line 25
> Plug-in Problem
> The folder "html/" does not exist in the workspace
>  build.properties  /org.apache.ibatis.ibator.eclipse.doc     line 2
> Plug-in Problem
>
> I last updated the local svn repo on March 4th.
>
> Brian
>
>
>
>
>
> -----Original Message-----
> From: Jeff Butler [mailto:jeffgbutler@gmail.com]
> Sent: Friday, March 12, 2010 11:03 AM
> To: user-java@ibatis.apache.org
> Subject: Re: Ibator 1.2.2 Eclipse jars not published
>
> The SVN repo has moved - glad you found the new one!  The "how to
> build" pages in SVN should be current - it sounds like you found the
> page for building the Eclipse feature.
>
> Ibator for Eclipse now builds with the headless PDE build process so a
> simple "Export" doesn't work anymore.  When you run the PDE build, the
> resulting file is placed on your hard drive in the
> \Temp\ibator.build\I.TestBuild directory.  You can unzip that file
> directly into an eclipse install and it should work fine.
>
> Jeff Butler
>
>
> On Fri, Mar 12, 2010 at 12:24 PM, Morearty, Brian
> <Brian_Morearty@intuit.com> wrote:
>> Hi,
>>
>>
>>
>> I am starting a new project with iBATIS 3 and Ibator. I am successfully
>> using Ibator 1.2.2 from the command line but we'd like to use the Eclipse
>> version of Ibator so we can add methods to the generated models and not
>> have
>> them clobbered.
>>
>>
>>
>> Can someone point me to instructions for either downloading or
>> building+installing Ibator 1.2.2 for Eclipse? (Since that's the version
>> that
>> supports iBATIS 3).
>>
>>
>>
>> Here's what I've tried so far:
>>
>> ·         I pointed Eclipse to the plugin install site at
>> http://ibatis.apache.org/tools/ibator/ but the newest version it has is
>> 1.2.1.
>>
>> ·         I went to the manual download site at
>> http://people.apache.org/builds/ibatis/ibator/ but the newest version it
>> has
>> is 1.2.1.
>>
>> ·         I tried the instructions at
>> http://ibatis.apache.org/docs/tools/ibator/reference/building.html but
>> they're out of date. The svn repo doesn't exist. Once I found an svn repo,
>> build.bat didn't exist.
>>
>> ·         I downloaded the source from
>> http://svn.apache.org/repos/asf/ibatis/java/ibator/trunk and followed the
>> instructions in the local version of buildingFromSVN.html. I was able to
>> build, but no JARs were created. I figured out I could right-click each
>> project and choose "Export..." and choose type JAR, then copy those JARs
>> to
>> IbatorUpdateSite\plugins. But I could not find a way to export the
>> "feature"
>> jar that goes into IbatorUpdateSite\features.
>>
>>
>>
>> Any advice?
>>
>>
>>
>> Thanks!
>>
>>
>>
>> Brian Morearty | Grow Your Business Division, Intuit | Staff Software
>> Engineer | direct 650-944-6852
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-java-unsubscribe@ibatis.apache.org
> For additional commands, e-mail: user-java-help@ibatis.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-java-unsubscribe@ibatis.apache.org
> For additional commands, e-mail: user-java-help@ibatis.apache.org
>
>

-- 
Sent from my mobile device

---------------------------------------------------------------------
To unsubscribe, e-mail: user-java-unsubscribe@ibatis.apache.org
For additional commands, e-mail: user-java-help@ibatis.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-java-unsubscribe@ibatis.apache.org
For additional commands, e-mail: user-java-help@ibatis.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-java-unsubscribe@ibatis.apache.org
For additional commands, e-mail: user-java-help@ibatis.apache.org


Mime
View raw message