ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Maves <nathan.ma...@gmail.com>
Subject Re: not known to the MapperRegistry with iBatis 3.0
Date Tue, 18 Aug 2009 15:33:33 GMT
Richard,
I took a quick look at your example code.  I also took a look at the source
and I think I see your issue.

You are trying to use a java only Mapper class.  This works but right now
the MapperRegistry getMapper method only looks though a collection of
mappers.  So for now you will need to register it with the MapperRegistry.
 Let me talk with the team about having the getMapper method also try to add
it for you if it can't find it.  Sounds like a reasonable request.

Nathan

On Tue, Aug 18, 2009 at 1:21 AM, RichadB <richard.bibb@aimhedge.com> wrote:

>
> Hi Clinton
>
> Given my inexperience I have zipped up my test eclipse project (don't worry
> it's pretty compact). and attached it. As far as I can tell it looks fine
> (you should notice that commenting out the explicit loading of the mapper
> causes the code to fail, uncommented things appear to work)
>
> Regards
>
> Richard
>
>
> Clinton Begin wrote:
> >
> > If you could write a quick unit test to demonstrate the broken
> > behavior, it might help.  Nathan just wrote a mapper and it was loaded
> > automatically, so something must be different somewhere...
> >
> > Note:  The namespace must equal the fully qualified name of the CLASS,
> > not the PACKAGE....
> >
> > Clinton
> >
> >  http://www.nabble.com/file/p25019720/MapperProblem.zipMapperProblem.zip
> --
> View this message in context:
> http://www.nabble.com/not-known-to-the-MapperRegistry-with-iBatis-3.0-tp25007484p25019720.html
> Sent from the iBATIS - User - Java mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-java-unsubscribe@ibatis.apache.org
> For additional commands, e-mail: user-java-help@ibatis.apache.org
>
>

Mime
View raw message