ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Brown <dbr...@sexingtechnologies.com>
Subject Re: IBatis noob/hibernate refugee
Date Tue, 09 Jun 2009 19:13:22 GMT
Hello Jeff, thanks for the speedy and informative reply. I am leaning toward Eclipse (if possible).
I have Googled and read some IBatis doco but I can't find the reason for the error condition
after adding the tag as requested: <classPathEntry>. Please find included below the
<jdbcConnection> criteria and the error condition. Thanks and please advise, David.

<jdbcConnection 
  driverClass="com.mysql.jdbc.Driver" 
  connectionURL="jdbc:mysql://localhost:3306/test" 
  userId="user" 
  password="test"> 
  <classPathEntry location="c:/Program Files/DbVisualizer-6.5.4/jdbc/mysql" />
</jdbcConnection>

*************************************
The content of element type "jdbcConnection" must match "(property)*"





----- Original Message -----
From: "Jeff Butler" <jeffgbutler@gmail.com>
To: user-java@ibatis.apache.org
Sent: Tuesday, June 9, 2009 12:26:08 PM GMT -06:00 US/Canada Central
Subject: Re: IBatis noob/hibernate refugee

With the eclipse plugin, you should add a <classPathyEntry> element to state
where the JDBC driver JAR is.

With command line, don't add the *iBATIS* JAR, instead add the *Ibator* JAR.

HTH -
Jeff Butler

On Tue, Jun 9, 2009 at 12:22 PM, David Brown
<dbrown@sexingtechnologies.com>wrote:

> Hello IBatis dev, gurus and mortals, I'm an IBatis noob fleeing from
> hibernate. I have a legacy database that will fair better under IBatis if I
> can get over the learning curve hump. In-all-likelihood this has been review
> before but my time constraints will not allow me to languish. I have
> installed both the Eclipse Ibatis plugin and the command line version. I
> both cases I am failing to generate anything. In Eclipse I have filled in
> the ibatorConfig.xml but when I right-click the ibatorConfig.xml file in the
> Eclipse to run the menu item: Generate IBATIS Artifacts I get a big red-X
> pop dialog the exclaims: Generation Failed. Reason: Unexpected error while
> running IBator: Exception getting JDBC driver.
>
> IF I attempt largely the same thing using the command-line:
>
> java -jar ..\..\..\st\dev_tools\ibatis\lib\ibatis-2.3.4.726.jar -configfile
> ibatorConfig.xml -overwrite
>
>
> I get the following error condition:
>
>
> ***************************************************
> Failed to load Main-Class manifest attribute from
> ..\..\..\st\dev_tools\ibatis\lib\ibatis-2.3.4.726.jar
>
>
>
> Any and all ideas for an IBatis noob will be greatly appreciated. Please
> advise, David.
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> There are 10 kinds of people in this world: those who understand binary and
> those who don’t (Valid only for 2's complement).
>

Mime
View raw message