ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish Kulkarni <ashish.kulkarn...@gmail.com>
Subject Re: How to test Pool.PingQuery with Simple Datasource
Date Wed, 06 May 2009 17:16:45 GMT
Hi Any ideas on this mail, how to test if Pool.PingQuery is working as
expected

On Mon, May 4, 2009 at 10:03 AM, Ashish Kulkarni <
ashish.kulkarni13@gmail.com> wrote:

> HiI have configured my data Source as below
> <transactionManager type="JDBC">
> <dataSource type="SIMPLE">
>  <property name="JDBC.Driver" value="com.ibm.as400.access.AS400JDBCDriver"
> />
> <property name="JDBC.ConnectionURL"
> value="jdbc:as400:MYAS400/MYDB;naming=system;date format=iso;time
> format=hms;prompt=false" />
>  <property name="JDBC.Username" value="user" />
> <property name="JDBC.Password" value="password" />
>  <property name="Pool.PingQuery"
> value="Select TYPE FROM APP_TYPE" />
>  <property name="Pool.PingEnabled" value="true" />
> <property name="Pool.PingConnectionsOlderThan" value="0" />
>  <property name="Pool.PingConnectionsNotUsedFor" value="0" />
> </dataSource>
> </transactionManager>
>
> In my Log4j.xml i have following lines to debug all queries, but i do not
> see any PingQuery log in my log files, what am i missing, what is the way to
> make sure that Pool.PingQuery is working as expected, i am going to
> change Pool.PingConnectionsOlderThan to 1800000 and
> Pool.PingConnectionsNotUsedFor to 1800000 so to use PingQuery if the
> connection is older then 30 minutes.
>
>  <category name="com.ibatis">
> <priority value="DEBUG" />
> </category>
> <category name="java.sql">
> <priority value="DEBUG" />
> </category>
>

Mime
View raw message