ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Duffey <tduf...@utilivisor.com>
Subject Re: spring 2.5.5 and ibatis 2.3.2
Date Mon, 07 Jul 2008 17:08:54 GMT

On Jul 7, 2008, at 12:05 PM, Brandon Goodin wrote:

> the pom is only in there because we are trying to move our compile  
> over to it. Don't use it. It is not ready and we don't run our  
> official build with it. Use the ant script.

For what it's worth, I used the Maven build and seem to have a working  
ibatis.jar with the patch for IBATIS-522.  I think all I had to do was  
switch the compiler source/target versions from 1.4 to 1.5 in pom.xml.

Tom

> On Mon, Jul 7, 2008 at 9:58 AM, Tom Duffey <tduffey@utilivisor.com>  
> wrote:
> FYI I also was unable to compile IBATIS when I checked out tags/ 
> java_release_2.3.2-715.  This is on Mac OS X and for some reason I  
> had to switch JAVA_HOME from 1.6 to 1.5 and also had to edit  
> something in your pom.xml.
>
> Maven drives me nuts so I have no idea why what I did worked.
>
> Tom
>
> On Jul 7, 2008, at 9:46 AM, Clinton Begin wrote:
>
>> Our source always compiles.   We have a continuous integration  
>> server that would alert us if it didn't. By practice the iBATIS  
>> trunk should be releasable if necessary.
>>
>> Which JDK/OS are you running?
>>
>> Clinton
>>
>> On Mon, Jul 7, 2008 at 8:39 AM, nch <underscore_dot@yahoo.com> wrote:
>>
>> Well, the only reason why I didn't decide to go for 2.3.2 is that I  
>> was confortable with 2.3.0 untill I found tomcat was not  
>> replicating sessions (I need this for clustering). So I took a look  
>> to 2.3.1 release notes which explicitly say "# [IBATIS-419] -  
>> LazyLoad object is not serializable."
>>
>> I tried to add the missing method to ExtendedSqlMapClient so,  
>> following instructions at http://opensource.atlassian.com/confluence/oss/display/IBATIS/Windows

>> , I checked out the sources from trunk but they don't compile at  
>> this moment or ... at, least, I was not able to compile them.
>>
>> Cheers.
>>
>> ----- Original Message ----
>> From: Clinton Begin <clinton.begin@gmail.com>
>> To: user-java@ibatis.apache.org
>> Sent: Monday, July 7, 2008 3:28:31 PM
>> Subject: Re: spring 2.5.5 and ibatis 2.3.2
>>
>> Darn, I guess not enough people tested it while it was in Beta.  :-/
>>
>> Perhaps we need a more formal testing group that can commit to  
>> testing the framework before we release it.  I know Brandon uses  
>> Spring and did make a couple of fixes for Spring, but he's just one  
>> person.
>>
>> Out of curiosity, why didn't you upgrade or at least test it while  
>> in Beta?
>>
>> In a nutshell, the answer to your question is this:
>>
>>   * We've deprecated a lot of internal interfaces in the core of  
>> iBATIS 2.3.2, in order to clean up the code.  One of those  
>> interfaces was ExtendedSqlMapClient.
>>
>>   * Code that used to cast (or othewise use) ExtendedSqlMapClient  
>> should now simply use SqlMapClientImpl (the default implementation  
>> behind the SqlMapClient interface).
>>
>> Cheers,
>> Clinton
>>
>> On Mon, Jul 7, 2008 at 2:41 AM, nch <underscore_dot@yahoo.com> wrote:
>>
>> Hi, there.
>>
>> I'm trying iBatis 2.3.2 with Spring 2.5.5.
>> Spring is complaining it can not find method  
>> com.ibatis.sqlmap.engine.impl.ExtendedSqlMapClient.getMappedStatement
>> This method was present in iBatis 2.3.0.
>> Is there a workaround I can take to make it work?
>> I need to test this cause it seems proxies coming from iBatis are  
>> now serializable, so I can replicate sessions amont tomcat instances.
>>
>> Cheers
>>
>>
>>
>>
>
>


Mime
View raw message