ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brandon Goodin" <brandon.goo...@gmail.com>
Subject Re: iBATIS insert does not execute
Date Fri, 18 Apr 2008 13:10:22 GMT
Is this the only insert that is not working for you? Do you have others that
are working? What version of iBATIS are you using?

Brandon Goodin

On Fri, Apr 18, 2008 at 7:10 AM, Chris Marshall <chris@campsbayterrace.com>
wrote:

> I have spent a couple of days on this and have read the FAQ and
> googled without success, so hope I can get some help:
> I am trying to persist an instance of the class:
>
> public class Role {
>
>    private Integer roleid;
>    private Integer parentid;
>    private String name;
>    private String notes;
>
>    public Integer getRoleid() {
>        return roleid;
>    }
> .......&c
> }
>
> with role_SqlMap.xml the snipprt:
>
>  <insert id="insert" parameterClass="net.mycompany.Role">
>    insert into role (RoleID, ParentID, Name, Notes)
>    values (#roleid:INTEGER#, #parentid:INTEGER#, #name:VARCHAR#,
> #notes:VARCHAR#)
>  </insert>
>
> and the java statement:
>
> sqlMap.insert("role.insert", role);
>
> which generates the folloing log entry:
>
> DEBUG [http-8888-Processor4] - {conn-100009} Preparing Statement:
> insert into role (RoleID, ParentID, Name, Notes)     values (?, ?, ?,
> ?)
>
> but no Executing Statement: or Parameters: entries.
> Also no exception is thrown nor is anything writtent to the (MySQL)
>  database.
>

Mime
View raw message