ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Glover <robertglove...@yahoo.com>
Subject Can anyone offer help on "There is no WRITEABLE property named 'lName'"
Date Fri, 17 Aug 2007 21:48:29 GMT
I'm at my wits end, tearing my hair out over this problem.
I use Abator to generate all my IBatis classes and XML.

When my Spring web app starts up I get this error:

Error parsing XPath '/sqlMap/resultMap/result'.
Cause: com.ibatis.common.beans.ProbeException:
There is no WRITEABLE property named 'lName' in class
'frb.bsd.abator.domain.IavAssetInfo2'

I have 27 tables, so I tried commenting out the offending table to see what
would happen then.  What happened is I got the same error but on a different
table.  That different table also had an "lName" property.

I did a lot of google-ing and most times this problem  is because manually
created iBatis XML has the wrong capitalization.  But I did not write any of
this, abator did.

   The offending tables have underscores in their table name, which Abator
removes.  I don't think that is it.  However in addition to that, the column
names in the tables have underscores.  The offending field, "lName", is
actually defined in the Oracle 10g database as "L_NAME".

    The abator generated set statements look okay to me. Here is one of them. I
don't see how this would cause the problem, so I'm at my wits end.

    /**
     * This method was generated by Abator for iBATIS.
     * This method sets the value of the database column
ATADMIN.IAV_ASSET_INFO2.L_NAME
     *
     * @param lName the value for ATADMIN.IAV_ASSET_INFO2.L_NAME
     *
     * @abatorgenerated Fri Aug 17 15:06:09 EDT 2007
     */
    public void setLName(String lName) {
        this.lName = lName;
    }

    





Mime
View raw message