ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Schlienger <s_gi...@yahoo.com>
Subject Log4j again... sorry
Date Fri, 31 Aug 2007 13:02:12 GMT
Hi everyone,

Sorry to bother you with that subject again, but I can not get any log, wether from ibatis
or from the java.sql BUT I do have spring logs and logs from my webapp code... My code uses
commons-logging AND log4j (I use a log4j.properties file)

I have read the documentation and I think I understand the dependency of iBatis with commons-logging...

My webapp uses Tomcat 5.5.23 and iBatis 2.3

I have in my webapp :
- in WEB-INF/lib: commons-loggingXX.jar and log4j-XX.jar
- in WEB-INF/classes: log4j.properties
with lines:
log4j.rootLogger=INFO, stdout

log4j.appender.stdout=org.apache.log4j.ConsoleAppender
log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
log4j.appender.stdout.layout.ConversionPattern=%d %p [%c] - <%m>%n
...
###### Logging configuration for IBATIS ######
# SqlMap logging configuration...
log4j.logger.com.ibatis=DEBUG
log4j.logger.java.sql.PreparedStatement=DEBUG

I do get my webapp personnal code logs, but I get nothing for ibatis and java.sql...

In Tomcat 5.5.23 by default, there is no jar about logging in common/lib but in the /bin directory
there is a commons-logging-api.jar

Could somebody help me please? That would be really appreciated
Thanks a lot in advance
Regards
Gilles





      _____________________________________________________________________________ 
Ne gardez plus qu'une seule adresse mail ! Copiez vos mails vers Yahoo! Mail 

Mime
View raw message